[bug#33759,v2,4/5] gnu: python-futures: Enable tests.

Message ID 20190103213452.1829-4-mail@cbaines.net
State Accepted
Headers show
Series [bug#33759,v2,1/5] gnu: linkchecker: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Christopher Baines Jan. 3, 2019, 9:34 p.m. UTC
Re-enable the tests, as the python-2 package now has the support
directory. Also, switch to running the tests via the test_futures.py script to
avoid errors like:

  AttributeError: 'AsCompletedTests' object has no attribute 'executor'

* gnu/packages/python.scm (python2-futures)[arguments]: Run the
test_futures.py script to run the tests.
---
 gnu/packages/python.scm | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 550643adb8..54bc1d4d02 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7918,11 +7918,14 @@  otherwise matches 3.2’s API.")
          (base32
           "0rdjmmsab550kxsssdq49jcniz77zlkpw4pvi9hvib3lsskjmh4y"))))
     (build-system python-build-system)
-    (arguments `(#:python ,python-2
-                 ;; FIXME: Python 2.7.14 moved the test.support library,
-                 ;; but our package has not yet been adjusted.  Enable
-                 ;; tests when the python2 package has been fixed.
-                 #:tests? #f))
+    (arguments
+     `(#:python ,python-2
+       #:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "python" "test_futures.py")
+             #t)))))
     (home-page "https://github.com/agronholm/pythonfutures")
     (synopsis
      "Backport of the concurrent.futures package from Python 3.2")