[bug#33759,v2,3/5] gnu: python-2.7: Include /lib/python.../test/support.

Message ID 20190103213452.1829-3-mail@cbaines.net
State Accepted
Headers show
Series [bug#33759,v2,1/5] gnu: linkchecker: Fix build. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 3, 2019, 9:34 p.m. UTC
Don't remove the support directory from the /lib/python.../test/ directory, as
this is used from the test_support module.

  /gnu/store/...-python2-2.7.15/lib/python2.7/test/test_support.py:2: in <module>
      import test.support
  E   ImportError: No module named support

* gnu/packages/python.scm (python-2.7)[arguments]: Change the 'remove-tests
phase to not remove the support directory.
---
 gnu/packages/python.scm | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 852beb73da..550643adb8 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -260,12 +260,9 @@ 
                                  (scandir testdir
                                           (match-lambda
                                             ((or "." "..") #f)
+                                            ("support" #f)
                                             (file
                                              (not
-                                              ;; FIXME: Add the 'support' directory
-                                              ;; in the next rebuild cycle, since it
-                                              ;; moved in 2.7.14.  See also
-                                              ;; python2-futures below.
                                               (string-prefix? "test_support."
                                                               file))))))
                        (call-with-output-file "__init__.py" (const #t))