[bug#33952,12/14] gnu: Add python-gast.

Message ID 20190102162512.28727-3-ricardo.wurmus@mdc-berlin.de
State Accepted
Headers show
Series [bug#33952,01/14] gnu: Add gemmlowp-for-tensorflow. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Ricardo Wurmus Jan. 2, 2019, 4:25 p.m. UTC
* gnu/packages/python.scm (python-gast): New variable.
---
 gnu/packages/python.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 93189d143..64d4b25ce 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15153,6 +15153,28 @@  factored out version of @code{unparse} found in the Python source
 distribution.")
     (license license:bsd-3)))
 
+(define-public python-gast
+  (package
+    (name "python-gast")
+    (version "0.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gast" version))
+       (sha256
+        (base32
+         "0c296xm1vz9x4w4inmdl0k8mnc0i9arw94si2i7pglpc461r0s3h"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-astunparse" ,python-astunparse)))
+    (home-page "https://pypi.org/project/gast/")
+    (synopsis "Generic Python AST that abstracts the underlying Python version")
+    (description
+     "GAST provides a compatibility layer between the AST of various Python
+versions, as produced by @code{ast.parse} from the standard @code{ast}
+module.")
+    (license license:bsd-3)))
+
 (define-public python-wikidata
   (package
     (name "python-wikidata")