[bug#33952,07/14] gnu: Add python-doctest-ignore-unicode.

Message ID 20190102161807.28297-7-ricardo.wurmus@mdc-berlin.de
State Accepted
Headers show
Series [bug#33952,01/14] gnu: Add gemmlowp-for-tensorflow. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Ricardo Wurmus Jan. 2, 2019, 4:18 p.m. UTC
* gnu/packages/python.scm (python-doctest-ignore-unicode): New variable.
---
 gnu/packages/python.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ad5c56427..4e9e19585 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15111,6 +15111,27 @@  RFC 8265 and RFC 8266.")
     (properties '((upstream-name . "Wikidata")))
     (license license:gpl3+)))
 
+(define-public python-doctest-ignore-unicode
+  (package
+    (name "python-doctest-ignore-unicode")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "doctest-ignore-unicode" version))
+       (sha256
+        (base32
+         "1m9aa4qnyj21lbq4sbvmv1vcz7zksss4rz37ddf2hxv4hk8b547w"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-nose" ,python-nose)))
+    (home-page "https://github.com/gnublade/doctest-ignore-unicode")
+    (synopsis "Ignore Unicode literal prefixes in doctests")
+    (description
+     "This package adds support for a flag to ignore Unicode literal prefixes
+in doctests.")
+    (license license:asl2.0)))
+
 (define-public python-attr
   (package
     (name "python-attr")