[bug#33916,1/4] gnu: gdm: Pass XDG_DATA_DIRS into session environment.

Message ID 20181230024204.4230-1-samplet@ngyro.com
State Accepted
Headers show
Series Make GDM usable | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Timothy Sample Dec. 30, 2018, 2:42 a.m. UTC
* gnu/packages/gnome.scm (gdm)[arguments]: Update the pre-configure
phase so that GDM preserves the XDG_DATA_DIRS variable when setting up
the session environment.
---
 gnu/packages/gnome.scm | 6 ++++++
 1 file changed, 6 insertions(+)

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 415398eee..da12a2987 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -32,6 +32,7 @@ 
 ;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
 ;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5399,6 +5400,11 @@  libxml2.")
                 ;; are met (provided GNOME is installed of course).
                 "gdm_session_set_environment_variable (self, \"XDG_CONFIG_DIRS\",\n"
                 "    \"/run/current-system/profile/etc/xdg\");\n"
+                ;; The session bus (which GDM will initialize from the this
+                ;; session environment) needs to know where to find the system
+                ;; service files.
+                "gdm_session_set_environment_variable (self, \"XDG_DATA_DIRS\",\n"
+                "    \"/run/current-system/profile/share\");\n"
                 )))
             ;; Look for custom GDM conf in /run/current-system.
             (substitute* '("common/gdm-settings-desktop-backend.c")