diff mbox series

[bug#63483,v2,2/4] build: Update the POT creation task with the po4a command.

Message ID 1fc791a888ce4bc45b6dabf0b7274b31fc0198c8.1713073114.git.gemmaro.dev@gmail.com
State New
Headers show
Series build: Update po4a process. | expand

Commit Message

gemmaro April 14, 2024, 7:18 a.m. UTC
* configure.ac (Documentation translation): Add the po4a program and remove
the po4a-updatepo program.  The PO4A defined here can be used in
Makefiles (e.g. po/doc/local.mk below).  The po4a command integrates the
functionality of po4a-updatepo and is currently recommended for use [1].  The
po4a-updatepo command has been replaced by the po4a command and are not used
from anywhere.
* po/doc/local.mk (%D%/%.pot): Use a po4a command instead of the po4a-updatepo
for the POT generation.  This eliminates the warning of po4a-updatepo;
"po4a-updatepo is deprecated.  The unified po4a(1) program is more convenient
and less error prone."  Here, the file paths are passed using variables.  This
is because the po4a command needs to be executed for each language and each
file.  Dummy values are passed for those that are not needed to update the POT
file.
* po/doc/po4a.cfg: Add a po4a config file for the POT generation.  The po4a
command requires a configulation file.

[1] https://po4a.org/man/man7/po4a.7.php.en#lbAS

Change-Id: Ica39a0d1f77b6a64d37c592ac2e693319443d3c5
---
 configure.ac    |  2 +-
 po/doc/local.mk | 10 ++++++++--
 po/doc/po4a.cfg | 32 ++++++++++++++++++++++++++++++++
 3 files changed, 41 insertions(+), 3 deletions(-)
 create mode 100644 po/doc/po4a.cfg
diff mbox series

Patch

diff --git a/configure.ac b/configure.ac
index ecbd596a34..68542f0348 100644
--- a/configure.ac
+++ b/configure.ac
@@ -262,8 +262,8 @@  dnl Manual pages.
 AM_MISSING_PROG([HELP2MAN], [help2man])
 
 dnl Documentation translation.
+AM_MISSING_PROG([PO4A], [po4a])
 AM_MISSING_PROG([PO4A_TRANSLATE], [po4a-translate])
-AM_MISSING_PROG([PO4A_UPDATEPO], [po4a-updatepo])
 
 case "$storedir" in
   /gnu/store)
diff --git a/po/doc/local.mk b/po/doc/local.mk
index dd6ba30133..8a78fb23f8 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -1,6 +1,7 @@ 
 # GNU Guix --- Functional package management for GNU
 # Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
 # Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+# Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
 #
 # This file is part of GNU Guix.
 #
@@ -44,8 +45,13 @@  POT_OPTIONS = \
 	--msgid-bugs-address "bug-guix@gnu.org"
 
 %D%/%.pot: $(srcdir)/doc/%.texi
-	$(AM_V_PO4A)$(PO4A_UPDATEPO) -M UTF-8 -f texinfo -m "$<" \
-	   -p "$@" $(POT_OPTIONS) && \
+	$(AM_V_PO4A)$(PO4A) --no-translations -M UTF-8	\
+		--package-version "$(VERSION)"		\
+		--variable master="$<"			\
+		--variable pot="$@"			\
+		--variable po=/dev/null			\
+		--variable localized=/dev/null		\
+		$(POT_OPTIONS) %D%/po4a.cfg
 	touch $@
 
 %D%/guix-manual.pot: %D%/guix.pot %D%/contributing.pot
diff --git a/po/doc/po4a.cfg b/po/doc/po4a.cfg
new file mode 100644
index 0000000000..7d2ef71773
--- /dev/null
+++ b/po/doc/po4a.cfg
@@ -0,0 +1,32 @@ 
+# GNU Guix --- Functional package management for GNU
+# Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
+#
+# This file is part of GNU Guix.
+#
+# GNU Guix is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or (at
+# your option) any later version.
+#
+# GNU Guix is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+# "--keep 0": produce an output even if the translation is not complete
+[options]                                                   \
+          --package-name "guix manual"                      \
+          --copyright-holder "the authors of Guix (msgids)" \
+          --msgid-bugs-address "bug-guix@gnu.org"           \
+          --master-charset UTF-8                            \
+          --localized-charset UTF-8                         \
+          --keep 0
+
+[po4a_langs] de es fr pt_BR ru zh_CN ko sk
+
+[po4a_paths] $(pot) $lang:$(po)
+
+[type:texinfo] $(master) $lang:$(localized)