diff mbox series

[bug#69652,gnome-team,v2,1/3] gnu: orbit2: Update style.

Message ID 1a1cf98038cc19b4212b055f74cf0bb9858d52cb.1709974034.git.vivien@planete-kraus.eu
State New
Headers show
Series FIX that damn orbit2 | expand

Commit Message

Vivien Kraus March 9, 2024, 7:48 a.m. UTC
* gnu/packages/gnome.scm (orbit2) [arguments]: Convert to list of G-Expressions.
[native-inputs]: Write the native-input list on one line.

Change-Id: I6a09616719c07cbb48195cf0c59d8b799c404d47
---
 gnu/packages/gnome.scm | 54 +++++++++++++++++++++---------------------
 1 file changed, 27 insertions(+), 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 13cad0add2..fa911e1e59 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3800,35 +3800,35 @@  (define-public orbit2
                 "0l3mhpyym9m5iz09fz0rgiqxl2ym6kpkwpsp1xrr4aa80nlh1jam"))))
     (build-system gnu-build-system)
     (arguments
-     `(;; The "timeout-server" test hangs when run in parallel.
-       #:parallel-tests? #f
-       #:configure-flags
-       '(;; We don't need static libraries, plus they don't build reproducibly
-         ;; (non-deterministic ordering of .o files in the archive.)
-         "--disable-static"
-
-         ;; The programmer kindly gives us a hook to turn off deprecation
-         ;; warnings ...
-         "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
-       ;; ... which they then completly ignore !!
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-parallel-build
-           ;; Parallel build fails because of a failed dependency,
-           ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
-           (lambda _
-             (substitute* "src/services/name/Makefile.am"
-               (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
-                "orbit_name_server_2_DEPENDENCIES = \
+     (list
+      ;; The "timeout-server" test hangs when run in parallel.
+      #:parallel-tests? #f
+      #:configure-flags
+      #~'(;; We don't need static libraries, plus they don't build reproducibly
+          ;; (non-deterministic ordering of .o files in the archive.)
+          "--disable-static"
+
+          ;; The programmer kindly gives us a hook to turn off deprecation
+          ;; warnings ...
+          "DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
+      ;; ... which they then completly ignore !!
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-parallel-build
+            ;; Parallel build fails because of a failed dependency,
+            ;; https://bugzilla.gnome.org/show_bug.cgi?id=732274
+            (lambda _
+              (substitute* "src/services/name/Makefile.am"
+                (("orbit_name_server_2_DEPENDENCIES = \\$(DEPS) CosNaming.h")
+                 "orbit_name_server_2_DEPENDENCIES = \
 $(DEPS) CosNaming.h libname-server-2.a"))))
-         (add-before 'configure 'ignore-deprecations
-           (lambda _
-             (substitute* "linc2/src/Makefile.in"
-               (("-DG_DISABLE_DEPRECATED")
-                "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
+          (add-before 'configure 'ignore-deprecations
+            (lambda _
+              (substitute* "linc2/src/Makefile.in"
+                (("-DG_DISABLE_DEPRECATED")
+                 "-DGLIB_DISABLE_DEPRECATION_WARNINGS")))))))
     (inputs (list glib libidl))
-    (native-inputs
-     (list pkg-config))
+    (native-inputs (list pkg-config))
     (home-page "https://projects.gnome.org/orbit2/")
     (synopsis "CORBA 2.4-compliant Object Request Broker")
     (description  "ORBit2 is a CORBA 2.4-compliant Object Request Broker (orb)