diff mbox series

[bug#70955,2/6] gnu: Add go-github-com-pion-transport-v3.

Message ID 191b5e32dd270afd3ec3440bd094372c7e0b85c9.1715753200.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns. | expand

Commit Message

Artyom V. Poptsov May 15, 2024, 6:17 a.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-pion-transport-v3): New variable.

Change-Id: I465da7f98a1f6c9d05c69fd5e3efd0a9de5a0b36
---
 gnu/packages/golang-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4ed310e9ef..c70e62d6c7 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3006,6 +3006,36 @@  (define-public go-github-com-pion-logging
 implementation.")
     (license license:expat)))
 
+(define-public go-github-com-pion-transport-v3
+  (package
+    (name "go-github-com-pion-transport")
+    (version "3.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pion/transport/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0j7ljkbyf2qd7daxg7d1rd6c92md64agi59b69g6jyqpz5jww998"))))
+    (build-system go-build-system)
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (propagated-inputs
+     (list go-github-com-pion-logging
+           go-golang-org-x-net
+           go-golang-org-x-sys))
+    (arguments
+     (list
+      #:import-path "github.com/pion/transport/v3"))
+    (home-page "https://github.com/pion/transport/")
+    (synopsis "Logging library used by @url{https://github.com/pion, Pion}")
+    (description
+     "The library is used as a part of @url{https://github.com/pion, Pion} WebRTC
+implementation.")
+    (license license:expat)))
+
 (define-public go-github-com-prometheus-client-model
   (package
     (name "go-github-com-prometheus-client-model")