diff mbox series

[bug#44596,2/2] gnu: knot-resolver: Move manual, examples to separate "doc" output

Message ID 16947e2029bd6bc38008f1019493365c403b0ee2.1605198478.git.simon@simonsouth.net
State Accepted
Headers show
Series gnu: knot-resolver: Update to 5.2.0; add "doc" output | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Simon South Nov. 12, 2020, 4:48 p.m. UTC
* gnu/packages/dns.scm (knot-resolver)[outputs]: Add "doc" output.
[arguments]<phases>: Add "move-doc" phase, which moves the manual (in both its
HTML and Info formats) and the example configuration files to the "doc"
output.
---
 gnu/packages/dns.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 784473d85f..6698bbf918 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -946,6 +946,7 @@  synthesis, and on-the-fly re-configuration.")
                (base32
                 "0cwlipib3x88dr6cijqv2aps13b4ijv524wc85ns07rkldy2c948"))))
     (build-system meson-build-system)
+    (outputs '("out" "doc"))
     (arguments
      '(#:configure-flags '("-Ddoc=enabled")
        #:phases
@@ -960,6 +961,20 @@  synthesis, and on-the-fly re-configuration.")
          (add-after 'build 'build-doc
            (lambda _
              (invoke "ninja" "doc")))
+         (add-after 'install 'move-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Move the manual and the example configuration files to the
+             ;; "doc" output.
+             (let ((out (assoc-ref outputs "out"))
+                   (doc (assoc-ref outputs "doc")))
+               (mkdir-p (string-append doc "/share/doc/knot-resolver"))
+               (for-each
+                (lambda (dir)
+                  (rename-file (string-append out "/share/" dir)
+                               (string-append doc "/share/" dir)))
+                '("doc/knot-resolver/examples"
+                  "doc/knot-resolver/html"
+                  "info")))))
          (add-after 'install 'wrap-binary
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))