diff mbox series

[bug#65037,v2,4/8] gnu: python-trezor: Update to 0.13.7.

Message ID 164e49f4e1812c4a6f5e1da7a8c7403b08a09bfc.1693421855.git.attila@lendvai.name
State New
Headers show
Series [bug#65037,v2,1/8] gnu: python-daemon: Build from git sources. | expand

Commit Message

Attila Lendvai Aug. 30, 2023, 6:57 p.m. UTC
* gnu/packages/finance.scm (python-trezor): Disable the sanity-check phase.
---
 gnu/packages/finance.scm | 25 +++++++++++++++----------
 1 file changed, 15 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e0d6bd6e2c..2d28de0ee4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1092,7 +1092,7 @@  (define-public python-btchip-python
 (define-public python-trezor
   (package
     (name "python-trezor")
-    (version "0.13.0")
+    (version "0.13.7")
     (source
      (origin
        (method git-fetch)
@@ -1101,7 +1101,7 @@  (define-public python-trezor
              (commit (string-append "python/v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1wy584bxx5p2av4lv1bx9hl1q0b5n7hqz0hnqb9shjriarvl5ckd"))
+        (base32 "13wyl9b15c8iscfakprwfvh2akw180hfqdjww79b78ywz51y7hdh"))
        (modules
         '((guix build utils)
           (srfi srfi-26)
@@ -1127,25 +1127,30 @@  (define-public python-trezor
     (build-system python-build-system)
     (propagated-inputs
      (list python-attrs
-           ;; TOOD: Use the latest click version after release 0.13.1 or later
-           ;; is made (see:
-           ;; https://github.com/trezor/trezor-firmware/issues/2199).
-           python-click-7
-           python-construct
+           python-click
+           python-construct-classes
            python-ecdsa
            python-hidapi
            python-libusb1
            python-mnemonic
            python-requests
            python-typing-extensions))
-    (native-inputs
-     ;; For tests.
+    (native-inputs ; Only needed for running the tests
      (list protobuf
            python-black
            python-isort
+           python-pillow
            python-protobuf
            python-pyqt
-           python-pytest))
+           python-pytest
+           python-simple-rlp
+           python-wheel))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; This package only has a Python script, not a Python module, so the
+         ;; sanity-check phase can't work.
+         (delete 'sanity-check))))
     (home-page "https://github.com/trezor/python-trezor")
     (synopsis "Python library for communicating with TREZOR Hardware Wallet")
     (description "@code{trezor} is a Python library for communicating with