diff mbox series

[bug#67905] gnu: Add emacs-golden-ratio.

Message ID 164a9b7538ce753d5a505eb6df221f36481aaf2f.1704377767.git.peter@polidoro.io
State New
Headers show
Series [bug#67905] gnu: Add emacs-golden-ratio. | expand

Commit Message

Peter Polidoro Jan. 4, 2024, 2:16 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-golden-ratio): New variable.

Change-Id: I44de02989b8dadd4a395374fe078d4255a210028
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 2f642b602398ab32b18faceecd074f49da92e95e

Comments

Nicolas Goaziou Jan. 21, 2024, 11:29 p.m. UTC | #1
Hello,

peter@polidoro.io writes:

> From: Peter Polidoro <peter@polidoro.io>
>
> * gnu/packages/emacs-xyz.scm (emacs-golden-ratio): New variable.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb3c905252..4f5aa5d1f7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1374,6 +1374,30 @@  (define-public emacs-project-mode-line-tag
 its mode line.")
       (license license:gpl3+))))
 
+(define-public emacs-golden-ratio
+  (let ((commit "375c9f287dfad68829582c1e0a67d0c18119dab9")
+        (revision "0"))
+    (package
+      (name "emacs-golden-ratio")
+      (version (git-version "1.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/roman/golden-ratio.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0a635a3h6jx0clgwmhwc48i14y3xy5q29y37lp2sjnbxx1hlmkli"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/roman/golden-ratio.el")
+      (synopsis "Automatic resizing of Emacs windows to the golden ratio")
+      (description "This package provides an Emacs mode for automatically
+resizing the window that has main focus to be more convenient for editing,
+while the ones that are not being actively edited will be reduced to a smaller
+size.")
+      (license license:expat))))
+
 (define-public emacs-git-modes
   (package
     (name "emacs-git-modes")