[bug#33545,1/2] gnu: petsc-openmpi: Configure with support for HYPRE preconditioner.

Message ID 1543434500-32200-1-git-send-email-pgarlick@tourbillion-technology.com
State Accepted
Commit af5236739e2d73132e7ae4678030f0ae4356729c
Headers show
Series Enable use of hypre via petsc | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Paul Garlick Nov. 28, 2018, 7:48 p.m. UTC
* gnu/packages/maths.scm (petsc-openmpi)[inputs]: Add hypre-openmpi.
[arguments]: Add 'with-hypre=1' flag.
---
 gnu/packages/maths.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0cf8916..85af458 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1767,6 +1767,7 @@  scientific applications modeled by partial differential equations.")
     (name "petsc-openmpi")
     (inputs
      `(("hdf5" ,hdf5-parallel-openmpi)
+       ("hypre" ,hypre-openmpi)
        ("metis" ,metis)
        ("mumps" ,mumps-openmpi)
        ("openmpi" ,openmpi)
@@ -1776,7 +1777,8 @@  scientific applications modeled by partial differential equations.")
     (arguments
      (substitute-keyword-arguments (package-arguments petsc)
        ((#:configure-flags cf)
-        ``("--with-mpiexec=mpirun"
+        ``("--with-hypre=1"
+           "--with-mpiexec=mpirun"
            "--with-metis=1"
            "--with-mumps=1"
            "--with-scalapack=1"