diff mbox series

[bug#43823,v2,3/3] gnu: knot: Fix test failure on aarch64-linux.

Message ID 11f47227ef927f18f0c8d77a26173247360128d9.1601991615.git.simon@simonsouth.net
State Accepted
Headers show
Series Knot: Enable DoH; build Info Manual; work on aarch64-linux | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Simon South Oct. 6, 2020, 1:56 p.m. UTC
* gnu/packages/dns.scm (knot)[source]: Apply patch from upstream that
helps ensure the "test_net_shortwrite" test suite can complete
regardless of platform or configuration.
* gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch:
New file.
* gnu/local.mk: Add it.
---
 gnu/local.mk                                  |  1 +
 gnu/packages/dns.scm                          |  2 ++
 ...est_net_shortwrite-ensure-connection.patch | 19 +++++++++++++++++++
 3 files changed, 22 insertions(+)
 create mode 100644 gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 59cad38504..83d2d72ab1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1198,6 +1198,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/kpackage-allow-external-paths.patch	\
   %D%/packages/patches/kmplayer-aarch64.patch			\
   %D%/packages/patches/kmplayer-upstream_Fix-build-with-Qt-5.9.patch	\
+  %D%/packages/patches/knot-test_net_shortwrite-ensure-connection.patch	\
   %D%/packages/patches/kobodeluxe-paths.patch			\
   %D%/packages/patches/kobodeluxe-enemies-pipe-decl.patch	\
   %D%/packages/patches/kobodeluxe-const-charp-conversion.patch	\
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b3dd68ccbd..97e919517c 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -815,6 +815,8 @@  Extensions} (DNSSEC).")
        (file-name (git-file-name name version))
        (sha256
         (base32 "0fkvip7n5ihjfwnnivdc3jf44y8p85ifglvq7b0anxvj9cg1m78f"))
+       (patches
+        (search-patches "knot-test_net_shortwrite-ensure-connection.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
diff --git a/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch b/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
new file mode 100644
index 0000000000..9e86fbdb58
--- /dev/null
+++ b/gnu/packages/patches/knot-test_net_shortwrite-ensure-connection.patch
@@ -0,0 +1,19 @@ 
+This patch duplicates upstream commit 4144d1e, which helps ensure the
+"test_net_shortwrite" test suite can succeed across all platforms by
+deepening the pending-connection queue of the server it creates from 0
+to 1.
+
+See the original report at
+https://gitlab.nic.cz/knot/knot-dns/-/issues/693
+
+--- a/tests/contrib/test_net_shortwrite.c
++++ b/tests/contrib/test_net_shortwrite.c
+@@ -88,7 +88,7 @@ int main(int argc, char *argv[])
+ 	int server = net_bound_socket(SOCK_STREAM, &addr, 0);
+ 	ok(server >= 0, "server: bind socket");
+ 
+-	r = listen(server, 0);
++	r = listen(server, 1);
+ 	ok(r == 0, "server: start listening");
+ 
+ 	struct sockaddr *sa = (struct sockaddr *)&addr;