diff mbox series

[bug#64257] gnu: Add r-scape.

Message ID 0ff3bbd121548e36163f14e26e7a7f176f3e5c02.1687542234.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#64257] gnu: Add r-scape. | expand

Commit Message

nafkhamdc June 23, 2023, 5:43 p.m. UTC
* gnu/packages/bioinformatics.scm (r-scape): New variable.
---
 gnu/packages/bioinformatics.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: f25529b08e356f89ca7cecc44295085531a8faba
prerequisite-patch-id: 363753ddc688e6cabad38e734df71a8fc2774458
prerequisite-patch-id: 7a61ca6199d8527299904ca6a1691387629363ac
prerequisite-patch-id: d7776816705dad2e89c2cbba5ef60c8bb63f9072
prerequisite-patch-id: 1840e69d148593f714371b464fa5a8c4186f3e9a
prerequisite-patch-id: 76e9473ae6bbeb3211f0d5a87d2f8a326858196a
prerequisite-patch-id: adfedba2ecd3adf84a823fdcbd7e10d1008bda5e
prerequisite-patch-id: 9f9fc73cc14add726decfc2ccf363ecd5f2d3b70
prerequisite-patch-id: 193a6447f90d6367cf2f8172b449b3f21eb5ae49
prerequisite-patch-id: e6d376726ae9bfc12c6f78ff5b42631135ba6257
prerequisite-patch-id: 638104f69e1f31bd61e397b557c586a1172802c0
prerequisite-patch-id: 8321754f27c7e2b1debec8f44a877eb5606c3075
prerequisite-patch-id: 57b54fcd4a657e74f95e544a3ed7e690f0f8eda6
prerequisite-patch-id: 318700c21a28feca889a3c42b2e771f3f3074ee7

Comments

Ricardo Wurmus June 29, 2023, 8:27 p.m. UTC | #1
Sorry for the delay.  I applied it with these minor changes:

- I renamed it to “rscape” for two reasons: the tarball and URL use
  “rscape” and this way we can avoid confusion with R packages that have
  the “r-” prefix.

- I used a versioned tarball, which happens to be version 2.0.0.q (same
  hash as the unversioned tarball you used), so I set the version to
  that string.

Thank you!  I pushed it with commit 94ac93042f09b4ba68b7b64ed1feeebd3dab1ea4.
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9de0470f7e..da3e1d10dc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17310,6 +17310,31 @@  (define-public r-scopeloomr
 files.")
       (license license:expat))))
 
+(define-public r-scape
+  (package
+    (name "r-scape")
+    (version "2.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://eddylab.org/software/rscape/rscape.tar.gz"))
+              (sha256
+               (base32
+                "1jabvm3fzh8iy4803ns12v1fsy28x6wdy8wx4ik8y0mfac4h787q"))))
+    (build-system gnu-build-system)
+    (propagated-inputs (list gsl openmpi))
+    (native-inputs (list automake autoconf))
+    (home-page "https://github.com/EddyRivasLab/R-scape")
+    (synopsis "RNA structural covariation above phylogenetic expectation")
+    (description
+     "R-scape discovers RNA secondary structure consensus elements.
+These elements include riboswitches and ribozymes.  It utilizes
+probabilistic modeling of sequence alignments, explicitly
+considering folding dependencies.  The tool enables the
+de novo search for new structural elements and facilitates
+comparative analysis of known RNA families.")
+    (license license:bsd-3)))
+
 (define-public r-seurat-utils
   (let ((commit "0b6f5b548a49148cfbeaa654e8a618c0a020afa5")
         (revision "1"))