diff mbox series

[bug#55753] gnu: Add emacs-color-theme-modern.

Message ID 0c50403e63f23e8ab35a282edb5b56d9c644eabf.1654190818.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#55753] gnu: Add emacs-color-theme-modern. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro June 2, 2022, 5:28 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Liliana Marie Prikler June 4, 2022, 7:52 a.m. UTC | #1
Am Donnerstag, dem 02.06.2022 um 13:28 -0400 schrieb peter@polidoro.io:
> From: Peter Polidoro <peter@polidoro.io>
> 
> * gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New
> variable.
Pushed with minor changes in synopsis, description and git-version
comment.

Thanks
Liliana Marie Prikler June 4, 2022, 8:34 a.m. UTC | #2
Am Samstag, dem 04.06.2022 um 09:52 +0200 schrieb Liliana Marie
Prikler:
> Am Donnerstag, dem 02.06.2022 um 13:28 -0400 schrieb
> peter@polidoro.io:
> > From: Peter Polidoro <peter@polidoro.io>
> > 
> > * gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New
> > variable.
> Pushed with minor changes in synopsis, description and git-version
> comment.
> 
> Thanks
Forgot to mark as done.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ced6e1a482..bbf8b6c343 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -110,6 +110,7 @@ 
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8464,6 +8465,29 @@  (define-public emacs-ahungry-theme
 dark background.")
     (license license:gpl3+)))
 
+(define-public emacs-color-theme-modern
+  ;; building a non-release commit since no release since October 2019
+  (let ((commit "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")
+        (revision "1"))
+    (package
+      (name "emacs-color-theme-modern")
+      (version (git-version "0.0.3" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/emacs-jp/replace-colorthemes.git")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacs-jp/replace-colorthemes")
+      (synopsis "Collection of Emacs themes originally from the color-themes package")
+      (description "This package contains several themes that were originally implemented
+with the venerable @code{color-themes} package, ported to Emacs' built-in custom themes.")
+      (license license:gpl3+))))
+
 (define-public emacs-gruvbox-theme
   (package
     (name "emacs-gruvbox-theme")