diff mbox series

[bug#47635] gnu: Add r-hmm.

Message ID 0c15c3cc79e536933ee8c4e6513e39d2e06a10c4.camel@gnu.org
State Accepted
Headers show
Series [bug#47635] gnu: Add r-hmm. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Roel Janssen April 7, 2021, 8:17 a.m. UTC
Dear Guix,

I'd like to add r-hmm. See attached patch.

Kind regards,
Roel Janssen

Comments

Ricardo Wurmus April 13, 2021, 11:56 a.m. UTC | #1
Hi Roel,

I pushed this after reindenting and using HTTPS for the home page.

Thanks!
diff mbox series

Patch

From 15be497145e041f9a53250437604a94a97f12bbb Mon Sep 17 00:00:00 2001
From: Roel Janssen <roel@gnu.org>
Date: Wed, 7 Apr 2021 10:14:35 +0200
Subject: [PATCH] gnu: Add r-hmm.

* gnu/packages/cran.scm (r-hmm): New variable.
---
 gnu/packages/cran.scm | 21 ++++++++++++++++++++-
 1 file changed, 20 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 044ad8f5bb..1b244bcc9a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3,7 +3,7 @@ 
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2020 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2017, 2018, 2020, 2021 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
@@ -1058,6 +1058,25 @@  the embedded @code{RapidXML} C++ library.")
 into a pipeline of data manipulation and visualisation.")
     (license license:gpl3)))
 
+(define-public r-hmm
+  (package
+   (name "r-hmm")
+   (version "1.0")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "HMM" version))
+            (sha256
+             (base32
+              "0z0hcqfixx1l2a6d3lpy5hmh0n4gjgs0jnck441akpp3vh37glzw"))))
+   (properties `((upstream-name . "HMM")))
+   (build-system r-build-system)
+   (home-page "http://cran.r-project.org/web/packages/HMM/")
+   (synopsis "Hidden Markov Models")
+   (description "This package provides an easy to use library to setup, apply
+and make inference with discrete time and discrete space hidden markov
+models.")
+   (license license:gpl2+)))
+
 (define-public r-httpuv
   (package
     (name "r-httpuv")
-- 
2.30.2