diff mbox series

[bug#68890,v4] gnu: pspp: Update to 2.0.0

Message ID 08452a3e3c96b30de134b5fddf17a3e28b9321d9.1708904696.git.atai@atai.org
State New
Headers show
Series [bug#68890,v4] gnu: pspp: Update to 2.0.0 | expand

Commit Message

Andy Tai Feb. 25, 2024, 11:45 p.m. UTC
* gnu/packages/statistics.scm (pspp): Update to 2.0.0
  [arguments](phases): Patch test case to make pass due to locale
  [native-inputs]: Switch from Python 2 to Python 3

Change-Id: I9feeab72789347033d2df8f23bda9ea27aaa7dd9
---
 gnu/packages/statistics.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)


base-commit: 05bbe9993f687da1fd684a31474c621f2a1c37b2

Comments

Ludovic Courtès Feb. 27, 2024, 10:21 a.m. UTC | #1
Andy Tai <atai@atai.org> skribis:

> * gnu/packages/statistics.scm (pspp): Update to 2.0.0
>   [arguments](phases): Patch test case to make pass due to locale
>   [native-inputs]: Switch from Python 2 to Python 3
>
> Change-Id: I9feeab72789347033d2df8f23bda9ea27aaa7dd9

[...]

>             #~(modify-phases %standard-phases
> -               (add-before 'check 'prepare-tests
> +         (add-after 'unpack 'patch-test-suite
> +				 (lambda _
> +				   (substitute* "tests/output/tex.at"
> +					   (("AT_CHECK\\(\\[LC_ALL=C.UTF-8 pspp")
> +						   "AT_CHECK([LC_ALL=en_US.UTF-8 pspp"))))

I adjusted indentation here and applied it, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 01d5e25a1a..05bdb589f7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -115,7 +115,7 @@  (define-module (gnu packages statistics)
 (define-public pspp
   (package
     (name "pspp")
-    (version "1.4.1")
+    (version "2.0.0")
     (source
      (origin
       (method url-fetch)
@@ -123,12 +123,17 @@  (define-public pspp
                           version ".tar.gz"))
       (sha256
        (base32
-        "0lqrash677b09zxdlxp89z6k02y4i23mbqg83956dwl69wc53dan"))))
+        "1pyqlab9kw65wxc8pilcwb64l18w37xxdg3r6n287c7mda4cpxm8"))))
     (build-system gnu-build-system)
     (arguments
      (list #:phases
            #~(modify-phases %standard-phases
-               (add-before 'check 'prepare-tests
+         (add-after 'unpack 'patch-test-suite
+				 (lambda _
+				   (substitute* "tests/output/tex.at"
+					   (("AT_CHECK\\(\\[LC_ALL=C.UTF-8 pspp")
+						   "AT_CHECK([LC_ALL=en_US.UTF-8 pspp"))))
+         (add-before 'check 'prepare-tests
                  ;; Prevent irrelevant errors that cause test output mismatches:
                  ;; ‘Fontconfig error: No writable cache directories’
                  (lambda _
@@ -149,7 +154,7 @@  (define-public pspp
            `(,glib "bin") ;for glib-genmarshal
            perl
            pkg-config
-           python-2 ;for tests
+           python-3 ;for tests
            texinfo))
     (home-page "https://www.gnu.org/software/pspp/")
     (synopsis "Statistical analysis")