diff mbox series

[bug#47864,1/3] gnu: Add marshmallow-3.2.

Message ID 082455aea4a75f65b5726ac65768a6e9@selfhosted.xyz
State New
Headers show
Series gnu: Add flask-combo-jsonapi | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

david larsson April 18, 2021, 6:48 a.m. UTC
From 5eb6db940c379e44a95b5a64382cc867f7d3c197 Mon Sep 17 00:00:00 2001
 From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:30:20 +0200
Subject: [PATCH 1/3] gnu: Add marshmallow-3.2.

* gnu/packages/python-xyz.scm (python-marshmallow-3.2): New variable.
---
  gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
  1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c90a89a411..872ba4b281 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -99,6 +99,7 @@ 
  ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
  ;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
  ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
  ;;;
  ;;; This file is part of GNU Guix.
  ;;;
@@ -17122,6 +17123,31 @@  Python datatypes.")
  complex datatypes to and from native Python datatypes.")
      (license license:expat)))

+(define-public python-marshmallow-3.2
+  (package
+    (name "python-marshmallow")
+    (version "3.2.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (pypi-uri "marshmallow" version))
+      (sha256
+       (base32
+        "1w18klwj0z9bqxj252qpj1hz8l46nl27sbc89rkajc7mln73wbws"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)
+       ("python-simplejson" ,python-simplejson)))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytz" ,python-pytz)))
+    (home-page "https://github.com/marshmallow-code/marshmallow")
+    (synopsis "Convert complex datatypes to and from native
+Python datatypes")
+    (description "@code{marshmallow} provides a library for converting
+complex datatypes to and from native Python datatypes.")
+    (license license:expat))) ; MIT license
+
  (define-public python-apispec
    (package
      (name "python-apispec")