diff mbox series

[bug#47864,3/3] gnu: Add flask-combo-jsonapi.

Message ID 60d19e93acb5c06eaa07388270db598c@selfhosted.xyz
State New
Headers show
Series gnu: Add flask-combo-jsonapi | expand

Commit Message

david larsson April 18, 2021, 6:57 a.m. UTC

diff mbox series

Patch

From 7e1c3d4e0c52a73c2369406c9165d0fff176a831 Mon Sep 17 00:00:00 2001
From: methuselah-0 <david.larsson@selfhosted.xyz>
Date: Wed, 31 Mar 2021 17:35:36 +0200
Subject: [PATCH 3/3] gnu: Add flask-combo-jsonapi.

* gnu/packages/python-web.scm (python-flask-combo-jsonapi): New variable.
---
 gnu/packages/python-web.scm | 40 +++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c7dd18ad19..8154ae82f7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5894,3 +5895,42 @@  your code non-blocking and speedy.")
      "Socks is a library providing core proxy (SOCKS4, SOCKS5, HTTP tunneling)
  functionality.")
     (license license:asl2.0)))
+
+(define-public python-flask-combo-jsonapi
+  (package
+    (name "python-flask-combo-jsonapi")
+    (version "1.0.6")
+    (source
+     (origin
+        (method url-fetch)
+        (uri (string-append
+              "https://github.com/AdCombo/flask-combo-jsonapi/archive/"
+              version ".tar.gz"))
+        (sha256
+         (base32
+           "1ik5j4cc20q6ismpdzpb1a01wpdhm9vrnlmqzxxz2qqw6vazilna"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-flask" ,python-flask)
+       ("python-marshmallow" ,python-marshmallow-3.2)
+       ("python-marshmallow-jsonapi"
+        ,python-marshmallow-jsonapi-0.22)
+       ("python-apispec" ,python-apispec)
+       ("python-simplejson" ,python-simplejson)
+       ("python-six" ,python-six)
+       ("python-sqlalchemy" ,python-sqlalchemy)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-coveralls" ,python-coveralls)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-pytest" ,python-pytest)))
+    (home-page
+     "https://github.com/AdCombo/flask-combo-jsonapi")
+    (synopsis
+     "Flask extension to create REST web api according to JSONAPI 1.0
+ specification")
+    (description
+     "Flask extension to create REST web api according to JSONAPI 1.0
+ specification with Flask, Marshmallow and data provider
+ of your choice (SQLAlchemy, MongoDB, ...)")
+    (license license:expat))) ; MIT license
-- 
2.30.2