diff mbox series

[bug#68150,3/8] gnu: libreoffice: Actually use glib-or-gtk-build-system.

Message ID 035edc6095b0f8e7c3bee5408d37e0d23d493a6e.1703953716.git.~@wolfsden.cz
State New
Headers show
Series Fix usage of glib-or-gtk-build-system | expand

Commit Message

Tomas Volf Dec. 30, 2023, 4:38 p.m. UTC
The #:modules argument was based on %glib-or-gtk-build-system-modules, which,
despite the name, should go into #:imported-modules.  When put into #:modules,
it leads to following warning:

    WARNING: (guile-user): `%standard-phases' imported from both (guix build glib-or-gtk-build-system) and (guix build gnu-build-system)

Due to the definition of %glib-or-gtk-build-system-modules

    `((guix build glib-or-gtk-build-system)
      ,@%gnu-build-system-modules)

It results in %standard-phases from gnu-build-system being used, effectively
turning glib-or-gtk-build-system with #:modules set to
%glib-or-gtk-build-system-modules into gnu-build-system.

The solution is to use the (now) exported default value of
 #:modules (%glib-or-gtk-build-system-default-modules) as a base of the
 #:modules.

* gnu/packages/libreoffice.scm (libreoffice)[arguments]<#:modules>: Use
%glib-or-gtk-build-system-default-modules instead of
%glib-or-gtk-build-system-modules.

Change-Id: I5304d9993af7d5f1187c6276e72a269aa60f5666
---
 gnu/packages/libreoffice.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 79b30cecaf..6368dbf5bb 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -915,7 +915,7 @@  (define-public libreoffice
                            ,@%glib-or-gtk-build-system-modules)
       #:modules `(((guix build python-build-system) #:select (python-version))
                   (ice-9 textual-ports)
-                  ,@%glib-or-gtk-build-system-modules)
+                  ,@%glib-or-gtk-build-system-default-modules)
       #:tests? #f                       ; Building the tests already fails.
       #:phases
       #~(modify-phases %standard-phases