mbox series

[bug#68150,0/8] Fix usage of glib-or-gtk-build-system

Message ID cover.1703953716.git.~@wolfsden.cz
Headers show
Series Fix usage of glib-or-gtk-build-system | expand

Message

Tomas Volf Dec. 30, 2023, 4:33 p.m. UTC
Using glib-or-gtk-build-system requires hard-coding the list of modules in
 #:modules.  Libreoffice and netsurf tried to use
%glib-or-gtk-build-system-modules instead, but that lead to crashes.

This series introduces new %glib-or-gtk-build-system-default-modules that
contains the list that should go into #:modules.  Using it in libreoffice and
netsurf fixes the mentioned crashes.  Other places were adjusted as well to
use it instead of copying over the list.  That would be hard to keep in sync.

Tomas Volf (8):
  build: glib-or-gtk: Export %glib-or-gtk-build-system-default-modules.
  gnu: netsurf: Actually use glib-or-gtk-build-system.
  gnu: libreoffice: Actually use glib-or-gtk-build-system.
  gnu: sugar: Dehardcode #:modules.
  gnu: sugar-datastore: Dehardcode #:modules.
  gnu: sugar-toolkit-gtk3: Dehardcode #:modules.
  gnu: nimf: Dehardcode #:modules.
  gnu: hime: Dehardcode #:modules.

 gnu/packages/language.scm         | 12 ++++--------
 gnu/packages/libreoffice.scm      |  2 +-
 gnu/packages/sugar.scm            | 15 ++++++---------
 gnu/packages/web.scm              |  2 +-
 guix/build-system/glib-or-gtk.scm |  9 +++++----
 5 files changed, 17 insertions(+), 23 deletions(-)


base-commit: f24b14767d362a84e6469682b4fe303b50f4b589
--
2.41.0