diff mbox series

[bug#68426,core-updates,1/1] gnu: flite: Fix build.

Message ID 01a83cb58c5a3e705670ad71887811b1115f19a1.1705157474.git.simon@simonsouth.net
State New
Headers show
Series gnu: flite: Fix build. | expand

Commit Message

Simon South Jan. 13, 2024, 3:10 p.m. UTC
* gnu/packages/patches/flite-build-with-make-4.4.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/speech.scm (flite)[source]: Apply it.

Change-Id: I263696c9571e2bcf97d5a4fc619124bce90d6799
---
 gnu/local.mk                                  |  1 +
 .../patches/flite-build-with-make-4.4.patch   | 24 +++++++++++++++++++
 gnu/packages/speech.scm                       |  3 ++-
 3 files changed, 27 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/flite-build-with-make-4.4.patch
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index c1833cd0dd..9b2957c9cb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1185,6 +1185,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/flann-cmake-3.11.patch			\
   %D%/packages/patches/flatpak-fix-path.patch			\
   %D%/packages/patches/flatpak-unset-gdk-pixbuf-for-sandbox.patch	\
+  %D%/packages/patches/flite-build-with-make-4.4.patch		\
   %D%/packages/patches/fluxbox-1.3.7-no-dynamic-cursor.patch	\
   %D%/packages/patches/fluxbox-1.3.7-gcc.patch			\
   %D%/packages/patches/fontconfig-cache-ignore-mtime.patch	\
diff --git a/gnu/packages/patches/flite-build-with-make-4.4.patch b/gnu/packages/patches/flite-build-with-make-4.4.patch
new file mode 100644
index 0000000000..d959bb73a5
--- /dev/null
+++ b/gnu/packages/patches/flite-build-with-make-4.4.patch
@@ -0,0 +1,24 @@ 
+Building flite with GNU Make 4.4 or newer fails with log messages like
+
+  making in main ...
+  gcc -g -O2 -Wall      -I../include  -c -o flitevox_info_main.o flitevox_info_main.c
+  making ../build/aarch64-linux-gnu/lib/libflite.so
+  make[1]: *** No rule to make target 'flite_voice_list.c', needed by 'all'.  Stop.
+
+This is due to a change in how the .NOTPARALLEL special make target is
+interpreted.  This patch causes the package to build as it did with earlier
+versions of Make.
+
+diff --git a/main/Makefile b/main/Makefile
+index 8166182..e5ba866 100644
+--- a/main/Makefile
++++ b/main/Makefile
+@@ -104,7 +104,7 @@ else
+ shared_libs: nothing
+ endif
+ 
+-.NOTPARALLEL: $(ALL)
++.NOTPARALLEL:
+ 
+ flite_lang_list: 
+ 	rm -f flite_lang_list.c
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 2ea8e4f64f..4009da9654 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -67,7 +67,8 @@  (define-public flite
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1n0p81jzndzc1rzgm66kw9ls189ricy5v1ps11y0p2fk1p56kbjf"))))
+        (base32 "1n0p81jzndzc1rzgm66kw9ls189ricy5v1ps11y0p2fk1p56kbjf"))
+       (patches (search-patches "flite-build-with-make-4.4.patch"))))
     (build-system gnu-build-system)
     (arguments
      ;; XXX: