[bug#77041,v2,00/16] Replacing mcron jobs by Shepherd timers

Message ID cover.1742642743.git.ludo@gnu.org
Headers
Series Replacing mcron jobs by Shepherd timers |

Message

Ludovic Courtès March 22, 2025, 11:36 a.m. UTC
  Hello Guix,

Here are the changes since v1:

  • Remove mcron deprecation and associated news entry.

  • Document timers and give examples under “Scheduled Job
    Execution” and “Shepherd Home Service”.  Recommend use
    of Shepherd timers rather than mcron.

  • Add ‘shepherd-timer’ procedure to reduce boilerplate, as
    suggested by Luis Guilherme Coelho.

  • Reintroduce missing quote in fstrim documentation.

Thoughts?

Ludo’.

Ludovic Courtès (16):
  services: shepherd: Factorize ‘trigger’ action.
  services: file-database: Turn into a Shepherd timer.
  services: file-database: Exclude /dev by default.
  services: package-database: Turn into a Shepherd timer.
  services: fstrim: Turn into a Shepherd timer.
  services: certbot: Turn into a Shepherd timer.
  services: wireguard: Turn monitoring into a Shepherd timer.
  tests: Make ‘operating-system-with-console-syslog’ public.
  tests: ganeti: Remove unnecessary ‘begin’.
  tests: ganeti: Write system log to /dev/console.
  tests: ganeti: Increase VM memory size.
  services: ganeti: Update to Shepherd 1.0 interface.
  services: ganeti: Produce Shepherd timers instead of mcron jobs.
  services: virtual-build-machine: Turn GC job into a Shepherd timer.
  services: shepherd: Add ‘shepherd-timer’.
  doc: Document Shepherd timers and recommend against mcron.

 doc/guix.texi                   | 208 ++++++++++++++++++++++++++++----
 gnu/home/services/shepherd.scm  |   4 +-
 gnu/services/admin.scm          |  68 +++++++----
 gnu/services/backup.scm         |   6 +-
 gnu/services/certbot.scm        |  93 +++++++-------
 gnu/services/ganeti.scm         | 135 ++++++++++-----------
 gnu/services/linux.scm          |  50 ++++----
 gnu/services/shepherd.scm       |  34 ++++++
 gnu/services/virtualization.scm |  22 +++-
 gnu/services/vpn.scm            | 199 +++++++++++++++---------------
 gnu/tests.scm                   |  21 ++++
 gnu/tests/ganeti.scm            | 120 +++++++++---------
 gnu/tests/install.scm           |  20 ---
 13 files changed, 607 insertions(+), 373 deletions(-)


base-commit: efac1498c15198afc4f9a2bc700408bde1b3b3ed
  

Comments

Maxim Cournoyer March 22, 2025, 12:12 p.m. UTC | #1
Hi,

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

If you apply this series to master with 'b4 shazam
cover.1742073920.git.ludo@gnu.org',  it should automatically add the
'Reviewed-by:' git trailers to every of these 15 commits.

Note that I haven't locally tested it, just reviewed the diffs, but I
trust your self-test/QA hygiene.
  
Ludovic Courtès March 23, 2025, 6:54 p.m. UTC | #2
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> If you apply this series to master with 'b4 shazam
> cover.1742073920.git.ludo@gnu.org',  it should automatically add the
> 'Reviewed-by:' git trailers to every of these 15 commits.

Impressive, didn’t know about it.  However it added a sign-off from me,
but not a ‘Reviewed-by’ tag, so I ended up doing that manually.

Pushed as 60e4012dfcbe0df5c7e60f097ae2b11d92f982ff.

Thanks everyone!

Ludo’.