mbox series

[bug#63314,0/2] Add PAM shepherd requirements

Message ID cover.1683308811.git.dev@jpoiret.xyz
Headers show
Series Add PAM shepherd requirements | expand

Message

Josselin Poiret May 5, 2023, 5:50 p.m. UTC
Hi everyone,

With shepherd 0.10 incoming, I've been running into a nasty issue: I use
elogind and greetd, and greetd, when starting needs to let its greeter log-in
through PAM.  However, its PAM entry requires pam_elogind.so, which might not
work if elogind isn't started yet, and so my greetd would just fail to start.
This patch adds a shepherd synchronization point for services needed by PAM,
and any PAM-using program should have the synchronization point as a
requirement.  I've mostly tested this with greetd only, so I would appreciate
if other PAM users could try it out.

Best,

Josselin Poiret (2):
  system: pam: Let PAM extenders add shepherd requirements.
  services: elogind: Add elogind as a shepherd PAM requirement.

 gnu/services/authentication.scm | 28 +++++++++--------
 gnu/services/base.scm           | 54 +++++++++++++++++---------------
 gnu/services/desktop.scm        | 45 +++++++++++++++------------
 gnu/services/kerberos.scm       | 44 +++++++++++++-------------
 gnu/services/lightdm.scm        |  2 +-
 gnu/services/mail.scm           |  4 +--
 gnu/services/pam-mount.scm      | 23 ++++++++------
 gnu/services/sddm.scm           |  2 +-
 gnu/services/ssh.scm            | 10 +++---
 gnu/services/xorg.scm           |  4 +--
 gnu/system/pam.scm              | 55 ++++++++++++++++++++++++++-------
 11 files changed, 161 insertions(+), 110 deletions(-)


base-commit: 6922069bcbe5c08da09c00e5aad44e390ebd1cc7