mbox series

[bug#61120,core-updates,0/1] gnu: mesa: Fix sporadic test failures.

Message ID cover.1674910858.git.simon@simonsouth.net
Headers show
Series gnu: mesa: Fix sporadic test failures. | expand

Message

Simon South Jan. 28, 2023, 1:30 p.m. UTC
On core-updates, I've found Mesa will sometimes fail its test suite with error
messages like

  ../mesa-22.2.4/src/gallium/drivers/r600/sfn/tests/sfn_instrfromstring_test.cpp:712: Failure
  Expected equality of these values:
    os.str()
      Which is: "WRITE_SCRATCH 20 R1.xyzw\xFF\xFF AL:4 ALO:16"
    init
      Which is: "WRITE_SCRATCH 20 R1.xyzw AL:4 ALO:16"

Turns out this is due to an uninitialized buffer in the test suite's code,
reported to upstream with issue 7021[0] and fixed with upstream commit
7749599d[1] in Mesa 22.3.0.

The patch to follow backports this commit to the version in core-updates,
22.2.4, and has eliminated these sporadic failures for me.

Tested on x86-64 and AArch64 and everything seems fine.

[0] https://gitlab.freedesktop.org/mesa/mesa/-/issues/7021

[1] https://gitlab.freedesktop.org/mesa/mesa/-/commit/7749599d737d205a88bbb6fa755ba095d9b581fa

--
Simon South
simon@simonsouth.net


Simon South (1):
  gnu: mesa: Fix sporadic test failures.

 gnu/local.mk                                  |  1 +
 gnu/packages/gl.scm                           |  4 ++-
 .../mesa-fix-sporadic-test-failures.patch     | 27 +++++++++++++++++++
 3 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/mesa-fix-sporadic-test-failures.patch


base-commit: 770d379d7b60590bfdcb749287cb6713dee093ce
prerequisite-patch-id: 418e6f2f834e0f77d4da64e48bf654d610fbfe80
prerequisite-patch-id: 7c9321685c0c33cb9d1438797d2cb2bb540276c4