mbox series

[bug#56298,0/7] Add python-cmsis-pack-manager and dependencies

Message ID cover.1656513323.git.peter@polidoro.io
Headers show
Series Add python-cmsis-pack-manager and dependencies | expand

Message

Peter Polidoro June 29, 2022, 2:46 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

I attempted to package python-cmsis-pack-manager, but I was not sure how to
create the package properly since it is a combination of Python and Rust
code. I think I included the dependencies properly, but there probably needs
to be some modifications to the build phases in order for the rust code to get
compiled properly and placed somewhere the Python code can find it. Can
someone please take a look when you have a chance and help me finish the
package? This package is itself a dependency for python-pyocd, which I hope to
package to enable flashing of embedded code to various boards using only Guix
packages. Thanks!

Peter Polidoro (7):
  gnu: Add python-milksnake.
  gnu: Add rust-quick-xml-0.17.
  gnu: Add rust-minidom-0.12.
  gnu: rust-rustversion-1: Update to 1.0.7.
  gnu: rust-anyhow-1: Update to 1.0.58.
  gnu: Add rust-loom-0.5.
  gnu: Add python-cmsis-pack-manager.

 gnu/packages/crates-io.scm  | 90 +++++++++++++++++++++++++++++++++----
 gnu/packages/embedded.scm   | 81 +++++++++++++++++++++++++++++++++
 gnu/packages/python-xyz.scm | 21 +++++++++
 3 files changed, 183 insertions(+), 9 deletions(-)