mbox series

[bug#53818,v2,0/7] Add Repology updater

Message ID cover.1644224421.git.public@yoctocell.xyz
Headers show
Series Add Repology updater | expand

Message

Xinglu Chen Feb. 7, 2022, 9:06 a.m. UTC
Hi,

The following changes have been made since v1:

* Sort the list of updaters to make generic ones come last.

* Make ‘json-fetch’ use ‘http-fetch/cached’ if the #:cached? argument is
  #t.

* Added some additional rules for converting Guix package names to
  Repology package names.

* Some typo fixes and more docstrings.

Xinglu Chen (7):
  upstream: Sort list of updaters.
  http-client: Make 'http-fetch/cached' take '#:headers' argument.
  http-client: 'http-fetch/cached' accepts a string or a <uri>.
  import: json: Make 'json-fetch' take '#:cached?' argument.
  import: Add 'repology' updater.
  gnu: xorg-server-xwayland: Set 'repology-name' property.
  gnu: xorg-server-xwayland: Prepare for cross-compilation.

 Makefile.am               |   3 +
 doc/guix.texi             |   7 ++
 gnu/packages/xorg.scm     |   8 +-
 guix/http-client.scm      |  18 ++-
 guix/import/json.scm      |  14 ++-
 guix/import/repology.scm  | 235 ++++++++++++++++++++++++++++++++++++++
 guix/upstream.scm         |  29 ++++-
 tests/import-repology.scm | 145 +++++++++++++++++++++++
 8 files changed, 441 insertions(+), 18 deletions(-)
 create mode 100644 guix/import/repology.scm
 create mode 100644 tests/import-repology.scm


base-commit: 7c9ad54b0616112c7eea6dd02379616aef206490