mbox series

[bug#62310,v2,0/4] gnu: fdroidcl: Update to 0.7.0.

Message ID 20230321080457.12236-1-sarg@sarg.org.ru
Headers show
Series gnu: fdroidcl: Update to 0.7.0. | expand

Message

Sergey Trofimov March 21, 2023, 8:04 a.m. UTC
I have addressed Maxim's comments and made the following changes:
* enabled tests.short for progressbar-v3 (full suite requires internet access)
* removed optional go-ansi dependency
* reworded synopsysises/descriptions, fixed formatting
* moved check-synopsis-style to %local-checkers, as I usually `lint -n` because of a very slow CVE linter

Sergey Trofimov (4):
  gnu: Add go-github-com-schollz-progressbar-v3.
  gnu: Add go-github-com-mitchellh-colorstring.
  gnu: fdroidcl: Update to 0.7.0.
  guix: Put check-synopsis-style to the local checkers list.

 gnu/packages/android.scm | 17 +++++------
 gnu/packages/golang.scm  | 63 ++++++++++++++++++++++++++++++++++++++++
 guix/lint.scm            |  9 +++---
 3 files changed, 75 insertions(+), 14 deletions(-)

Comments

Maxim Cournoyer March 21, 2023, 6:09 p.m. UTC | #1
Hi,

Sergey Trofimov <sarg@sarg.org.ru> writes:

> I have addressed Maxim's comments and made the following changes:
> * enabled tests.short for progressbar-v3 (full suite requires internet access)
> * removed optional go-ansi dependency
> * reworded synopsysises/descriptions, fixed formatting
> * moved check-synopsis-style to %local-checkers, as I usually `lint -n` because of a very slow CVE lin

Thanks for the lightning fast response!

I've retouched progressbar-v3 cosmetics a tiny bit:

--8<---------------cut here---------------start------------->8---
@@ -11358,13 +11358,13 @@ (define-public go-github-com-schollz-progressbar-v3
            go-github-com-mattn-go-isatty
            go-github-com-davecgh-go-spew))
     (home-page "https://github.com/schollz/progressbar")
-    (synopsis "Simple CLI progress bar")
+    (synopsis "Simple command-line interface (CLI) progress bar")
     (description
      "This package provides a very simple thread-safe progress bar.  The
-@code{progressbar} implements an @code{io.Writer} so it can automatically detect the
-number of bytes written to a stream, so you can use it as a progressbar for an
-@code{io.Reader}.  When progressbar length is undetermined a customizable spinner is
-shown.")
+@code{progressbar} implements an @code{io.Writer} so it can automatically
+detect the number of bytes written to a stream, so you can use it as a
+@code{progressbar} for an @code{io.Reader}.  When @code{progressbar}'s length
+is undetermined, a customizable spinner is shown.")
     (license license:expat)))
--8<---------------cut here---------------end--------------->8---

And installed the series.

Thank you!