diff mbox series

[bug#62310,v2,2/4] gnu: Add go-github-com-schollz-progressbar-v3.

Message ID 20230321081640.16012-1-sarg@sarg.org.ru
State New
Headers show
Series gnu: fdroidcl: Update to 0.7.0. | expand

Commit Message

Sergey Trofimov March 21, 2023, 8:16 a.m. UTC
* gnu/packages/golang.scm
(go-github-com-schollz-progressbar-v3): New variable.
---
 gnu/packages/golang.scm | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3ac4863e85..8f0e202d71 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11326,6 +11326,47 @@  (define-public go-github-com-mitchellh-colorstring
      "Colorstring provides functions for colorizing strings for terminal output.")
     (license license:expat)))
 
+(define-public go-github-com-schollz-progressbar-v3
+  (package
+    (name "go-github-com-schollz-progressbar-v3")
+    (version "3.13.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/schollz/progressbar")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hjahr5r52i7w6iyvl3rpzr46iignhfdh4694fl7m2b4gkaw9gd6"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "github.com/schollz/progressbar/v3"
+           #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? import-path #:allow-other-keys)
+                   (when tests?
+                     ;; tests in the full suite require internet access
+                     (invoke "go" "test" "-test.short" import-path))
+                   #t)))))
+    (propagated-inputs
+     (list go-golang-org-x-term
+           go-github-com-stretchr-testify
+           go-github-com-mitchellh-colorstring
+           go-github-com-mattn-go-runewidth
+           go-github-com-mattn-go-isatty
+           go-github-com-davecgh-go-spew))
+    (home-page "https://github.com/schollz/progressbar")
+    (synopsis "Simple CLI progress bar")
+    (description
+     "This package provides a very simple thread-safe progress bar.  The
+@code{progressbar} implements an @code{io.Writer} so it can automatically detect the
+number of bytes written to a stream, so you can use it as a progressbar for an
+@code{io.Reader}.  When progressbar length is undetermined a customizable spinner is
+shown.")
+    (license license:expat)))
+
 (define-public go-git-sr-ht-emersion-go-scfg
   (package
     (name "go-git-sr-ht-emersion-go-scfg")