mbox series

[bug#57533,core-updates,0/5] glibc 2.35 and GCC 11

Message ID 20220901222413.14482-1-marius@gnu.org
Headers show
Series glibc 2.35 and GCC 11 | expand

Message

Marius Bakke Sept. 1, 2022, 10:24 p.m. UTC
Hello Guix,

These patches updates glibc to a recent (but not the latest) version,
and switches to GCC 11.

I can build up to GNOME, IceCat and ungoogled-chromium with these
patches and consider them ready for merge to core-updates.

There are some issues however:

  * IcedTea bootstrap fails in mysterious ways (I'm looking into it).
  * The 'guix' package needs to be updated and refer to this branch for
    the changes to (guix build syscalls); or the procedures need to
    somehow be made compatible with old and new glibc's.
  * glibc 2.33 fails to build, so locales compatible with 'master' are
    not currently available.
  * GCC 5.5.0 fails to build.

Volunteers to work on these problems wanted!

Marius Bakke (4):
  syscalls: Adjust for glibc 2.34 and later.
  gnu: Switch to GCC 11.
  gnu: glm: Fix build with GCC 11.
  gnu: clang-runtime: Remove obsolete workaround.

zamfofex (1):
  gnu: glibc: Update to 2.35.

 gnu/packages/base.scm                         | 34 +++++++++++-
 gnu/packages/commencement.scm                 | 55 ++++++++++++++++---
 gnu/packages/gcc.scm                          | 33 +++++++++--
 gnu/packages/llvm.scm                         |  6 +-
 gnu/packages/maths.scm                        |  9 ++-
 .../glibc-hurd-clock_gettime_monotonic.patch  |  4 +-
 guix/build/syscalls.scm                       |  6 +-
 7 files changed, 121 insertions(+), 26 deletions(-)

Comments

Marius Bakke Sept. 8, 2022, 7:48 p.m. UTC | #1
Marius Bakke <marius@gnu.org> skriver:

> Marius Bakke (4):
>   syscalls: Adjust for glibc 2.34 and later.
>   gnu: Switch to GCC 11.
>   gnu: glm: Fix build with GCC 11.
>   gnu: clang-runtime: Remove obsolete workaround.
>
> zamfofex (1):
>   gnu: glibc: Update to 2.35.

Merged in 27322ac30b..8ea970a945 !

I have a couple other big changes coming up, with Python 3.10 and
OpenSSL 3.0 ... then I'm done, promise!  ;-)