mbox series

[bug#55997,staging,v2,0/5] Remove texlive's dependence on mariadb.

Message ID 20220624110838.21580-1-tom@tom-fitzhenry.me.uk
Headers show
Series Remove texlive's dependence on mariadb. | expand

Message

Tom Fitzhenry June 24, 2022, 11:08 a.m. UTC
While rebuilding my simple server, I noticed mariadb being compiled, which
didn't seem right.

$ guix graph --path guix mariadb
guix@1.3.0-27.598f728
po4a@0.63
texlive-tiny@59745
texlive-latex-base@59745
texlive-hyphen-afrikaans@59745
ruby-hydra@0.0-0.5abfa37
ruby-byebug@11.1.3
ruby-rubocop@1.10.0
ruby-parallel@1.21.0
ruby-mysql2@0.5.2
mariadb@10.5.12

This patch series cuts the texlive to ruby-byebug dependency, by introducing
ruby-hydra-minimal, a minimal variant of ruby-hydra that doesn't depend on
ruby-byebug.

This also enabled the cleanup of ruby-nokogiri-1.10.

Tests performed:
--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix build guix ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff texlive-hyphen-afrikaans
[... success ...]
$ ./pre-inst-env guix style      ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff texlive-hyphen-afrikaans
[... ignored unrelated changes ...]
$ ./pre-inst-env guix lint       ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff texlive-hyphen-afrikaans
gnu/packages/ruby.scm:3135:14: warning: no tags were found for ruby-hydra-minimal
gnu/packages/ruby.scm:3135:14: ruby-hydra-minimal@0.0-0.5abfa37: updater 'github' failed to find upstream releases
gnu/packages/ruby.scm:3160:8: ruby-hydra@0.0-0.5abfa37: the 'check' phase should respect #:tests?
gnu/packages/ruby.scm:3156:2: warning: no tags were found for ruby-hydra
gnu/packages/ruby.scm:3156:2: ruby-hydra@0.0-0.5abfa37: updater 'github' failed to find upstream releases
gnu/packages/tex.scm:1647:2: texlive-hyphen-afrikaans@59745: no updater for texlive-hyphen-afrikaans
gnu/packages/tex.scm:1647:2: texlive-hyphen-afrikaans@59745: source not archived on Software Heritage and missing from the Disarchive database
--8<---------------cut here---------------end--------------->8---


Changes since v1:
* Added a Description field to the patches.
* Removed input labels on texlive-hyphen-package.
* lint: Renamed the patch filename to begin with the package name.
* lint: Split long line.


Tom Fitzhenry (5):
  gnu: Add ruby-hydra-minimal.
  gnu: Remove texlive's dependence on ruby-rspec and ruby-byebug.
  gnu: Unpin ruby-nokogiri-diff's ruby-nokogiri
  gnu: Remove unused ruby-nokogiri-1.10.
  gnu: texlive-hyphen-package: Remove input labels.

 gnu/local.mk                                  |  2 +
 .../ruby-hydra-minimal-no-byebug.patch        | 11 +++
 .../patches/texlive-hyph-utf8-no-byebug.patch | 13 +++
 gnu/packages/ruby.scm                         | 87 +++++++------------
 gnu/packages/tex.scm                          |  8 +-
 5 files changed, 61 insertions(+), 60 deletions(-)
 create mode 100644 gnu/packages/patches/ruby-hydra-minimal-no-byebug.patch
 create mode 100644 gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch


base-commit: 66e3adcad8cb07962d75e89d562057ded9946348

Comments

Tom Fitzhenry June 29, 2022, 9:32 a.m. UTC | #1
Tom Fitzhenry <tom@tom-fitzhenry.me.uk> writes:
> Tests performed:
>
> $ ./pre-inst-env guix build guix ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff texlive-hyphen-afrikaans
> [... success ...]
> $ ./pre-inst-env guix style      ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff texlive-hyphen-afrikaans
> [... ignored unrelated changes ...]
> $ ./pre-inst-env guix lint       ruby-hydra-minimal ruby-hydra
> ruby-nokogiri-diff texlive-hyphen-afrikaans

Are there any additional tests that I could perform to give confidence
in this patch series?
Thiago Jung Bauermann July 1, 2022, 2:07 a.m. UTC | #2
Hello Tom,

Tom Fitzhenry <tom@tom-fitzhenry.me.uk> writes:

> Tom Fitzhenry <tom@tom-fitzhenry.me.uk> writes:
>> Tests performed:
>>
>> $ ./pre-inst-env guix build guix ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff
>> texlive-hyphen-afrikaans
>> [... success ...]
>> $ ./pre-inst-env guix style ruby-hydra-minimal ruby-hydra ruby-nokogiri-diff
>> texlive-hyphen-afrikaans
>> [... ignored unrelated changes ...]
>> $ ./pre-inst-env guix lint       ruby-hydra-minimal ruby-hydra
>> ruby-nokogiri-diff texlive-hyphen-afrikaans
>
> Are there any additional tests that I could perform to give confidence
> in this patch series?

These patches look great to me! Thanks for addressing the review
comments.

Sorry for the delay.
Ludovic Courtès Aug. 8, 2022, 3:25 p.m. UTC | #3
Hello,

Tom Fitzhenry <tom@tom-fitzhenry.me.uk> skribis:

>   gnu: Add ruby-hydra-minimal.
>   gnu: Remove texlive's dependence on ruby-rspec and ruby-byebug.
>   gnu: Unpin ruby-nokogiri-diff's ruby-nokogiri
>   gnu: Remove unused ruby-nokogiri-1.10.
>   gnu: texlive-hyphen-package: Remove input labels.

Finally applied on ‘staging’.

Thanks for this improvement, and thanks Thiago for reviewing!

Ludo’.