diff mbox series

[bug#55997,staging,v2,5/5] gnu: texlive-hyphen-package: Remove input labels.

Message ID 20220624110838.21580-6-tom@tom-fitzhenry.me.uk
State Accepted
Headers show
Series Remove texlive's dependence on mariadb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tom Fitzhenry June 24, 2022, 11:08 a.m. UTC
* gnu/packages/tex.scm (texlive-hyphen-package): Remove input labels.
---
 gnu/packages/tex.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2eb27fa057..e7f20bbea3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -187,7 +187,8 @@  (define (texlive-hyphen-package name code locations hash)
                          (string-append root "/tex/generic/hyph-utf8/patterns/quote")))
                    (mkdir "scripts")
                    (copy-recursively
-                    (assoc-ref inputs "hyph-utf8-scripts") "scripts")
+                    (dirname (search-input-file inputs "hyph-utf8.rb"))
+                    "scripts")
 
                    ;; Prepare target directories
                    (mkdir-p patterns)
@@ -225,9 +226,7 @@  (define (texlive-hyphen-package name code locations hash)
                         (string-append "File.join(\"" ptex "\"")))
                      (invoke "ruby" "generate-ptex-patterns.rb")))))))))
       (native-inputs
-       `(("ruby" ,ruby)
-         ("ruby-hydra-minimal" ,ruby-hydra-minimal)
-         ("hyph-utf8-scripts" ,hyph-utf8-scripts)))
+       (list ruby ruby-hydra-minimal hyph-utf8-scripts))
       (home-page "https://ctan.org/pkg/hyph-utf8"))))
 
 (define texlive-extra-src