mbox series

[bug#52165,core-updates-frozen,0/2] Add KAlgebra.

Message ID 20211128165432.263822-1-monego@posteo.net
Headers show
Series Add KAlgebra. | expand

Message

Vinicius Monego Nov. 28, 2021, 4:54 p.m. UTC
Vinicius Monego (2):
  gnu: Add analitza.
  gnu: Add kalgebra.

 gnu/packages/kde.scm | 69 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 69 insertions(+)


base-commit: 612e38bd29a42409cd6030d745ead844509e8c6e

Comments

Leo Famulari Nov. 29, 2021, 2:55 a.m. UTC | #1
On Sun, Nov 28, 2021 at 04:54:32PM +0000, Vinicius Monego wrote:
> Vinicius Monego (2):
>   gnu: Add analitza.
>   gnu: Add kalgebra.

Thanks for the patches.

Will they work on the master branch or do they require something from
core-updates-frozen?
Vinicius Monego Nov. 29, 2021, 3:29 a.m. UTC | #2
Em dom, 2021-11-28 às 21:55 -0500, Leo Famulari escreveu:
> On Sun, Nov 28, 2021 at 04:54:32PM +0000, Vinicius Monego wrote:
> > Vinicius Monego (2):
> >   gnu: Add analitza.
> >   gnu: Add kalgebra.
> 
> Thanks for the patches.
> 
> Will they work on the master branch or do they require something from
> core-updates-frozen?

They may work on the master branch but I only tested on core-updates-
frozen.
Leo Famulari Nov. 30, 2021, 6:03 p.m. UTC | #3
On Mon, Nov 29, 2021 at 03:29:30AM +0000, Vinicius Monego wrote:
> Em dom, 2021-11-28 às 21:55 -0500, Leo Famulari escreveu:
> > On Sun, Nov 28, 2021 at 04:54:32PM +0000, Vinicius Monego wrote:
> > > Vinicius Monego (2):
> > >   gnu: Add analitza.
> > >   gnu: Add kalgebra.
> > 
> > Thanks for the patches.
> > 
> > Will they work on the master branch or do they require something from
> > core-updates-frozen?
> 
> They may work on the master branch but I only tested on core-updates-
> frozen.

The packages do build on the master branch. Unless they require
something that only exists on core-updates-frozen, we should introduce
new packages on the master branch.

I noticed that analitza doesn't keep a reference to eigen:

------
$ guix gc --references $(./pre-inst-env guix build --no-grafts analitza)
/gnu/store/01b4w3m6mp55y531kyi1g8shh722kwqm-gcc-7.5.0-lib
/gnu/store/a0dn3jlq6862mcngzyw0lkcks066pcam-qtsvg-5.15.2
/gnu/store/a2ngdffc2133m5a211f42pyhypcbr9qa-qtbase-5.15.2
/gnu/store/dk7l3sn0wchyddgl7r2ka80zzwzhfm02-qtdeclarative-5.15.2
/gnu/store/f98v0niqzjm0lfl3zpf7qi538j3kf76j-analitza-21.08.3
/gnu/store/fa6wj5bxkj5ll1d7292a70knmyl7a0cr-glibc-2.31
------

Can you check if it is actually able to use the functionality provided
by eigen at run-time? Do we need to pass some flags to the linker or
something? Is eigen used only while building? Etc...

Similar question for kalgebra regarding kdoctools and ncurses. The built
package does not refer to these inputs.
Ludovic Courtès Dec. 5, 2021, 3:41 p.m. UTC | #4
Hi,

Leo Famulari <leo@famulari.name> skribis:

> I noticed that analitza doesn't keep a reference to eigen:

That’s expected because Eigen is a C++ “header-only” library: it doesn’t
provide a shared library.

HTH,
Ludo’.
Leo Famulari Dec. 6, 2021, 4:26 a.m. UTC | #5
On Sun, Dec 05, 2021 at 04:41:50PM +0100, Ludovic Courtès wrote:
> Leo Famulari <leo@famulari.name> skribis:
> 
> > I noticed that analitza doesn't keep a reference to eigen:
> 
> That’s expected because Eigen is a C++ “header-only” library: it doesn’t
> provide a shared library.

Thanks for the clarification.

> > Similar question for kalgebra regarding kdoctools and ncurses. The built
> > package does not refer to these inputs.

I'm guessing that kdoctools is used only while building. I submitted
<https://issues.guix.gnu.org/52323> based on that.

So what do we think about ncurses?
Ludovic Courtès Dec. 6, 2021, 12:21 p.m. UTC | #6
Hi,

Leo Famulari <leo@famulari.name> skribis:

>> > Similar question for kalgebra regarding kdoctools and ncurses. The built
>> > package does not refer to these inputs.

[...]

> So what do we think about ncurses?

It’s likely that ncurses is not used if there’s no residual reference to it.

Ludo’.