diff mbox series

[bug#52165,core-updates-frozen,1/2] gnu: Add analitza.

Message ID 20211128165546.263952-1-monego@posteo.net
State New
Headers show
Series Add KAlgebra. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Nov. 28, 2021, 4:55 p.m. UTC
* gnu/packages/kde.scm (analitza): New variable.
---
 gnu/packages/kde.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Mathieu Othacehe Dec. 12, 2021, 7:05 p.m. UTC | #1
Hello,

> +    (version "21.08.3")

The linter reports that the 21.12.0 revision is out there, for this
package as well as for the other one.

Thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index b5c2357cb4..94e46af99f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1054,6 +1054,35 @@  Python, PHP, and Perl.")
 a variety of formats, including PDF, PostScript, DejaVu, and EPub.")
     (license license:gpl2+)))
 
+(define-public analitza
+  (package
+    (name "analitza")
+    (version "21.08.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://invent.kde.org/education/analitza")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1qqi3kk4lcf838w99ab4yxbiq6b70jbzm0b35rb189bzw38mxh79"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("eigen" ,eigen)
+       ("qtbase" ,qtbase-5)
+       ("qtdeclarative" ,qtdeclarative)
+       ("qtsvg" ,qtsvg)))
+    (home-page "https://invent.kde.org/education/analitza")
+    (synopsis "Library to add mathematical features to a program")
+    (description "Analitza is a library to work with mathematical objects.
+It adds mathematical features to your program, such as symbolic computations
+and some numerical methods; for instance the library can parse mathematical
+expressions and let you evaluate and draw them.")
+    (license license:gpl2+)))
+
 (define-public poxml
   (package
     (name "poxml")