mbox series

[bug#51346,v3,0/5] Rework swap device to add dependencies and flags

Message ID 20211115202631.6032-1-dev@jpoiret.xyz
Headers show
Series Rework swap device to add dependencies and flags | expand

Message

Josselin Poiret Nov. 15, 2021, 8:26 p.m. UTC
Hello Tobias and Ludovic,

Thanks for the review!  Here is hopefully the last patchset, which
addresses most of the issues.

I decided not to merge the doc changes with the first commit as it
also describes swap flags, but that's just a matter of taste I
suppose.

Moved the deprecation warning that I originally put in
gnu/services/base.scm (swap-service) to a sanitizer of swap-devices in
its own commit, although it only reports the location of the
(operating-system) syntax use, not of the field itself (but that is
what I also noticed for other deprecation warnings, alas).  I marked
the field as delayed, otherwise I was getting a lot of warnings while
testing rather than the only one I'm getting now.

Fixed the swap-device dependency filtering to silently ignore
old-style values rather than erroring out.

Overall, I cleaned up all the rogue TABs I had inserted!
(setq-default indent-tabs-mode nil) for our Emacs readers at home.
This should not happen any more as I have set whitespace-mode to an
aggressive red highlighting for TAB characters.

And finally, I changed the examples at the end to simply be @lisp
blocks, outside of a table.

Josselin Poiret (5):
  gnu: system: Rework swap space support, add dependencies.
  gnu: system: Warn about swap-devices format change
  gnu: system: Add swap flags.
  gnu: system: Filter out boot dependencies from swap-space.
  doc: Add new Swap Space section.

 doc/guix.texi                    | 147 +++++++++++++++++++++++--------
 gnu/build/file-systems.scm       |  36 +++++++-
 gnu/services/base.scm            | 105 +++++++++++++++-------
 gnu/system.scm                   |  40 ++++++++-
 gnu/system/examples/desktop.tmpl |   7 +-
 gnu/system/file-systems.scm      |  24 ++++-
 guix/build/syscalls.scm          |  12 +++
 7 files changed, 294 insertions(+), 77 deletions(-)