mbox series

[bug#50018,00/19] Update Celery to version 5.

Message ID 20210811234345.32228-1-monego@posteo.net
Headers show
Series Update Celery to version 5. | expand

Message

Vinicius Monego Aug. 11, 2021, 11:43 p.m. UTC
Vinicius Monego (19):
  gnu: Add python-click-repl.
  gnu: Add python-click-didyoumean.
  gnu: Add python-pytest-subtests.
  gnu: python-aws-sam-translator: Update to 1.38.0.
  gnu: python-aws-sam-translator: Change source for tests.
  gnu: python-cfn-lint: Update to 0.53.0.
  gnu: python-cfn-lint: Respect #:tests?.
  gnu: python-moto: Update to 2.2.2.
  gnu: python-moto: Respect #:tests?.
  gnu: python-vine: Update to 5.0.0.
  gnu: Add python-pytest-rerunfailures.
  gnu: python-amqp: Update to 5.0.6.
  gnu: python-kombu: Update to 5.1.0.
  gnu: Add python-pytest-celery.
  gnu: python-celery: Update to 5.1.2.
  gnu: python-celery: Enable tests.
  gnu: Remove python2-celery.
  gnu: Remove python2-kombu.
  gnu: Remove python2-amqp.

 gnu/packages/python-check.scm |  76 ++++++++++
 gnu/packages/python-web.scm   | 100 +++++++-----
 gnu/packages/python-xyz.scm   | 276 +++++++++++++++++++++++-----------
 3 files changed, 323 insertions(+), 129 deletions(-)

Comments

Vinicius Monego Sept. 16, 2021, 4:20 p.m. UTC | #1
This v3 skips patches 4 and 6 because they were pushed from another set.

It also adds updates to botocore, s3transfer, boto3 and awscli to enable more tests in python-moto which is also updated to 2.2.7.

I noticed that there is intention to package MediaGoblin which requires celery < 4.3.0 in setup.cfg [1]. The latest Celery 4 version is 4.4.7. Will MediaGoblin be updated to Celery 5? Other web apps have moved to celery 5 by now (Weblate, Flaskbb...)

Patches 1-11 should be non-controversial. An older version of celery can also be added later if needed.

Vinicius Monego (21):
  gnu: Add python-click-repl.
  gnu: Add python-click-didyoumean.
  gnu: Add python-pytest-subtests.
  gnu: python-cfn-lint: Respect #:tests?.
  gnu: python-botocore: Update to 1.21.42.
  gnu: python-s3transfer: Update to 0.5.0.
  gnu: python-boto3: Update to 1.18.42.
  gnu: awscli: Update to 1.20.42.
  gnu: python-aws-sam-translator: Change source for tests.
  gnu: python-moto: Update to 2.2.7.
  gnu: python-moto: Respect #:tests?.
  gnu: python-vine: Update to 5.0.0.
  gnu: Add python-pytest-rerunfailures.
  gnu: python-amqp: Update to 5.0.6.
  gnu: python-kombu: Update to 5.1.0.
  gnu: Add python-pytest-celery.
  gnu: python-celery: Update to 5.1.2.
  gnu: python-celery: Enable tests.
  gnu: Remove python2-celery.
  gnu: Remove python2-kombu.
  gnu: Remove python2-amqp.
Vinicius Monego Oct. 25, 2021, 8 p.m. UTC | #2
> This needs to be something like (search-input-file "bin/sh") instead
> for cross-compiling python-moto (though python-build-system doesn't
> support cross-compilation currently), with "bash-minimal" added to
> the inputs.
> 
> Or (string-append (assoc-ref inputs "bash-minimal") "/bin/sh"),
> because search-input-file is only in core-updates and core-updates-
> frozen, and not yet in master.
> 
> Greetings,
> Maxime

I submitted the python-moto update in the new issue #51396 with the
suggested change.

I will hold the Celery update until the moto update is merged, to make
it easier to review since some of the patches in this series are only
for moto. This would reduce the number of Celery patches to 13.
Nicolas Goaziou Dec. 26, 2021, 11:10 p.m. UTC | #3
Hello,

Vinicius Monego <monego@posteo.net> writes:

> Vinicius Monego (19):
>   gnu: Add python-click-repl.
>   gnu: Add python-click-didyoumean.
>   gnu: Add python-pytest-subtests.
>   gnu: python-aws-sam-translator: Update to 1.38.0.
>   gnu: python-aws-sam-translator: Change source for tests.
>   gnu: python-cfn-lint: Update to 0.53.0.
>   gnu: python-cfn-lint: Respect #:tests?.
>   gnu: python-moto: Update to 2.2.2.
>   gnu: python-moto: Respect #:tests?.
>   gnu: python-vine: Update to 5.0.0.
>   gnu: Add python-pytest-rerunfailures.
>   gnu: python-amqp: Update to 5.0.6.
>   gnu: python-kombu: Update to 5.1.0.
>   gnu: Add python-pytest-celery.
>   gnu: python-celery: Update to 5.1.2.
>   gnu: python-celery: Enable tests.
>   gnu: Remove python2-celery.
>   gnu: Remove python2-kombu.
>   gnu: Remove python2-amqp.

I applied v4 of this patch set. Thanks.

Regards,
Leo Famulari Dec. 26, 2021, 11:39 p.m. UTC | #4
On Mon, Dec 27, 2021 at 12:10:46AM +0100, Nicolas Goaziou wrote:
> Vinicius Monego <monego@posteo.net> writes:
[...]
> >   gnu: Add python-pytest-rerunfailures.
> 
> I applied v4 of this patch set. Thanks.

We already had this package, so I reverted the commit.