diff mbox series

[bug#50018,15/19] gnu: python-celery: Update to 5.1.2.

Message ID 20210811234511.32450-15-monego@posteo.net
State Accepted
Headers show
Series Update Celery to version 5. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vinicius Monego Aug. 11, 2021, 11:45 p.m. UTC
* gnu/packages/python-xyz.scm (python-celery): Update to 5.1.2.
[source]: Make some cosmetic changes.
[propagated-inputs]: Add python-boto3, python-click, python-click-didyoumean,
python-click-plugins, python-click-repl, python-cryptography, python-vine.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++------
 1 file changed, 13 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f14f40e55e..175bab1b89 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13335,14 +13335,13 @@  Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
 (define-public python-celery
   (package
     (name "python-celery")
-    (version "4.2.1")
+    (version "5.1.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "celery" version))
        (sha256
-        (base32
-         "0y66rz7z8dfcgs3s0qxmdddlaq57bzbgxgfz896nbp14grkv9nkp"))))
+        (base32 "1c6lw31i3v81fyj4yn37lbvv70xdgb389iccirzyjr992vlkv6ld"))))
     (build-system python-build-system)
     (arguments
      '(;; TODO The tests fail with Python 3.7
@@ -13360,9 +13359,17 @@  Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
      `(("python-case" ,python-case)
        ("python-pytest" ,python-pytest)))
     (propagated-inputs
-     `(("python-pytz" ,python-pytz)
-       ("python-billiard" ,python-billiard)
-       ("python-kombu" ,python-kombu)))
+     `(("python-billiard" ,python-billiard)
+       ("python-boto3" ,python-boto3)
+       ("python-click" ,python-click)
+       ("python-click-didyoumean"
+        ,python-click-didyoumean)
+       ("python-click-plugins" ,python-click-plugins)
+       ("python-click-repl" ,python-click-repl)
+       ("python-cryptography" ,python-cryptography)
+       ("python-kombu" ,python-kombu)
+       ("python-pytz" ,python-pytz)
+       ("python-vine" ,python-vine)))
     (home-page "https://celeryproject.org")
     (synopsis "Distributed Task Queue")
     (description "Celery is an asynchronous task queue/job queue based on