mbox series

[bug#49272,00/10] broken Python 2 packages removal

Message ID 20210629130758.14400-1-zimon.toutoune@gmail.com
Headers show
Series broken Python 2 packages removal | expand

Message

Simon Tournier June 29, 2021, 1:07 p.m. UTC
Hi,

Because Python 2 is EOL and these packages fail to build, there are removed.
At the end of the series, "make as-derivation" successes, so everything seems
fine.  Note that because sometimes the graph is rewritten, the dependency
graph needs some care.

Last, note that python2-terminado is broken because of the rewrite of
'python-tornado-6'; replacing instead by 'python2-tornado' does not fix the
build, at least at first quick look.  It is not worth to try to keep it build,
IMHO.

Cheers,
simon


zimoun (10):
  gnu: python2-nbconvert: Remove package.
  gnu: python2-jupyter-client: Remove package.
  gnu: python2-ipython: Remove package.
  gnu: python2-nbformat: Remove package.
  gnu: python2-terminado: Remove package.
  gnu: python2-toolz: Remove package.
  gnu: python2-testpath: Remove package.
  gnu: python2-pyzmq: Remove package.
  gnu: python2-pyfakefs: Remove package.
  gnu: python2-pgpdump: Remove package.

 gnu/packages/check.scm         |   8 +--
 gnu/packages/python-crypto.scm |  31 ---------
 gnu/packages/python-web.scm    |  12 +---
 gnu/packages/python-xyz.scm    | 121 +--------------------------------
 4 files changed, 3 insertions(+), 169 deletions(-)


base-commit: 5ed105a8bb1a812975496dc3a091596355a0234c

Comments

Efraim Flashner July 5, 2021, 7:17 a.m. UTC | #1
On Tue, Jun 29, 2021 at 03:07:58PM +0200, zimoun wrote:
> Hi,
> 
> Because Python 2 is EOL and these packages fail to build, there are removed.
> At the end of the series, "make as-derivation" successes, so everything seems
> fine.  Note that because sometimes the graph is rewritten, the dependency
> graph needs some care.
> 
> Last, note that python2-terminado is broken because of the rewrite of
> 'python-tornado-6'; replacing instead by 'python2-tornado' does not fix the
> build, at least at first quick look.  It is not worth to try to keep it build,
> IMHO.
> 
> Cheers,
> simon

Looks good to me! Patches pushed.