[bug#48262,version-1.3.0,0/3] Enable SPICE for the Guix VM image.

Message ID 20210506172355.11694-1-maxim.cournoyer@gmail.com
Headers show
Series Enable SPICE for the Guix VM image. | expand

Message

Maxim Cournoyer May 6, 2021, 5:23 p.m. UTC
These three patches enable the use of the SPICE protocol for the VM image,
which provides benefits such as dynamically resizing the display of
the guest, sharing the clip-board, smoother mouse support, etc.

To test, generate the image with something like:

$ image=$(./pre-inst-env guix system image -t qcow2 gnu/system/examples/vm-image.tmpl)
$ cp $image /tmp/vm-test.qcow2
$ chmod +w /tmp/vm-test.qcow2

Then launch a SPICE-capable solution such as GNOME Boxes, and enjoy!

I'd like to have these patches included in the RC2 that will go out later today.

Thanks,

Maxim Cournoyer (3):
  gnu: spice-vdagent: Update to 0.21.0 and enable GTK+ support.
  services: spice-vdagent: Clear the socket file prior to starting.
  gnu: system: Add SPICE capability to the VM image.

 gnu/packages/spice.scm            | 26 +++++++++++++++++++-------
 gnu/services/spice.scm            | 31 +++++++++++++++----------------
 gnu/system/examples/vm-image.tmpl | 11 ++++++++++-
 3 files changed, 44 insertions(+), 24 deletions(-)