Message ID | 20190127170820.28937-3-mail@cbaines.net |
---|---|
State | Accepted |
Commit | 6edabcb20ce7df0133cc5ff77a27f4635dfc7573 |
Headers | show |
Series | Add ruby-rubocop and dependencies. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Christopher Baines <mail@cbaines.net> writes: > Required for ruby-rubocop. > > * gnu/packages/ruby.scm (ruby-rainbow): New variable. LGTM!
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm index 223ff30ba8..cd756a8b9a 100644 --- a/gnu/packages/ruby.scm +++ b/gnu/packages/ruby.scm @@ -3771,6 +3771,38 @@ clickjacking, directory traversal, session hijacking and IP spoofing.") (home-page "https://github.com/sinatra/sinatra/tree/master/rack-protection") (license license:expat))) +(define-public ruby-rainbow + (package + (name "ruby-rainbow") + (version "3.0.0") + (source + (origin + (method url-fetch) + (uri (rubygems-uri "rainbow" version)) + (sha256 + (base32 + "0bb2fpjspydr6x0s8pn1pqkzmxszvkfapv0p4627mywl7ky4zkhk")))) + (build-system ruby-build-system) + (arguments + '(#:phases + (modify-phases %standard-phases + ;; Run rspec directly, to avoid requiring Rubocop which is used from + ;; the Rakefile. + (replace 'check + (lambda* (#:key tests? #:allow-other-keys) + (when tests? + (invoke "rspec")) + #t))))) + (native-inputs + `(("bundler" ,bundler) + ("ruby-rspec" ,ruby-rspec))) + (synopsis "Colorize printed text on ANSI terminals") + (description + "@code{rainbow} provides a string presenter object to colorize strings by +wrapping them in ANSI escape codes.") + (home-page "https://github.com/sickill/rainbow") + (license license:expat))) + (define-public ruby-contest (package (name "ruby-contest")