[bug#34222,07/15] gnu: Add ruby-webmock.

Message ID 20190127170820.28937-7-mail@cbaines.net
State Accepted
Headers show
Series Add ruby-rubocop and dependencies. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 27, 2019, 5:08 p.m. UTC
Required by ruby-rest-client. Also at version ~> 2, so don't package 3 just
yet.

* gnu/packages/ruby.scm (ruby-webmock): New variable.
---
 gnu/packages/ruby.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Ricardo Wurmus Jan. 27, 2019, 5:32 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> Required by ruby-rest-client. Also at version ~> 2, so don't package 3 just
> yet.
>
> * gnu/packages/ruby.scm (ruby-webmock): New variable.

[…]

When version 3 is already available, I’d prefer to explicitly name this
“ruby-webmock-2”, so that other people know it is on purpose.

> +    (propagated-inputs
> +     `(("bundler" ,bundler)

Does “bundler” really need to be propagated?

--
Ricardo
Christopher Baines Jan. 27, 2019, 6:53 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> writes:

> Christopher Baines <mail@cbaines.net> writes:
>
>> Required by ruby-rest-client. Also at version ~> 2, so don't package 3 just
>> yet.
>>
>> * gnu/packages/ruby.scm (ruby-webmock): New variable.
>
> […]
>
> When version 3 is already available, I’d prefer to explicitly name this
> “ruby-webmock-2”, so that other people know it is on purpose.

Sure, I've updated the patch and the other dependant patches.

>> +    (propagated-inputs
>> +     `(("bundler" ,bundler)
>
> Does “bundler” really need to be propagated?

Good spot. Indeed bundler doesn't need to be propagated, and this wasn't
the only issue with the inputs. They now are as follows:

+    (native-inputs
+     `(("bundler" ,bundler)
+       ("ruby-rspec" ,ruby-rspec)))
+    (propagated-inputs
+     `(("ruby-addressable" ,ruby-addressable)
+       ("ruby-crack" ,ruby-crack)
+       ("ruby-hashdiff" ,ruby-hashdiff)))

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e11900b835..5eb08d9929 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4781,6 +4781,32 @@  support to both Ruby and JRuby.  It uses @code{unf_ext} on CRuby and
     (home-page "https://github.com/knu/ruby-unf")
     (license license:bsd-2)))
 
+(define-public ruby-webmock
+  (package
+    (name "ruby-webmock")
+    (version "2.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "webmock" version))
+       (sha256
+        (base32
+         "04hkcqsmbfnp8g237pisnc834vpgildklicbjbyikqg0bg1rwcy5"))))
+    (build-system ruby-build-system)
+    (propagated-inputs
+     `(("bundler" ,bundler)
+       ("ruby-addressable" ,ruby-addressable)
+       ("ruby-crack" ,ruby-crack)
+       ("ruby-public-suffic" ,ruby-public-suffix)
+       ("ruby-rspec" ,ruby-rspec)
+       ("ruby-hashdiff" ,ruby-hashdiff)))
+    (synopsis "Allows stubbing and setting expectations on HTTP requests")
+    (description
+     "WebMock allows stubbing HTTP requests and setting expectations on HTTP
+requests.  This is useful when testing software.")
+    (home-page "https://github.com/bblimke/webmock")
+    (license license:expat)))
+
 (define-public ruby-domain-name
   (package
     (name "ruby-domain-name")