[bug#34204,2/3] gnu: Add Python LiveReload.

Message ID 20190126002849.7707-2-mthl@gnu.org
State Accepted
Headers show
Series Mkdocs and its dependencies | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Mathieu Lirzin Jan. 26, 2019, 12:28 a.m. UTC
* gnu/packages/python-web.scm (python-livereload): New variable.
---
 gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ricardo Wurmus Jan. 26, 2019, 1:35 p.m. UTC | #1
Mathieu Lirzin <mthl@gnu.org> writes:

> * gnu/packages/python-web.scm (python-livereload): New variable.

LGTM!

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 19ff7d2dc4..24fa4ec60a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2923,3 +2923,25 @@  underlies Mozilla Persona.")
      "This is a Python library for interacting with the Firefox Accounts
 ecosystem.")
     (license license:mpl2.0)))
+
+(define-public python-livereload
+  (package
+    (name "python-livereload")
+    (version "2.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "livereload" version))
+              (sha256
+               (base32
+                "19s9lrzq33ds3d580q99y0zg8f1vhyz6afpisz0mb49l3p6sccp6"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-six" ,python-six)
+       ("python-tornado" ,python-tornado)))
+    (home-page "https://github.com/lepture/python-livereload")
+    (synopsis "Live reload server in Python")
+    (description
+     "This provides the @code{livereload} command line utility for starting a
+server in a directory.  By default, it listens to port 35729 which is the
+common port for LiveReload browser extensions.")
+    (license license:bsd-3)))