[bug#34159] Fix sporadic test failures in mariadb

Message ID MLNpJt_CixA3iqwZmqVKPNdjMzX8xy852GTBJ7SKnZHa8aesUr4hsHn-g0F78H815sW44E66sVwaohPhjZIYiwHBk7vLdsYKJFeplXGuhiM=@carldong.me
State Accepted
Headers show
Series [bug#34159] Fix sporadic test failures in mariadb | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Carl Dong Jan. 21, 2019, 4:59 p.m. UTC
From 6963ef73ccfbbc2e22a2b90b567d65cf37a2be0a Mon Sep 17 00:00:00 2001
From: Carl Dong <accounts@carldong.me>
Date: Mon, 21 Jan 2019 11:53:05 -0500
Subject: [PATCH] gnu: mariadb: Disable sporadically failing tests.

* guix/packages/databases.scm: Disable sporadically failing tests.
---
 gnu/packages/databases.scm | 2 ++
 1 file changed, 2 insertions(+)

--
2.20.1

Comments

Christopher Baines Jan. 22, 2019, 7:23 a.m. UTC | #1
Carl Dong <accounts@carldong.me> writes:

> From 6963ef73ccfbbc2e22a2b90b567d65cf37a2be0a Mon Sep 17 00:00:00 2001
> From: Carl Dong <accounts@carldong.me>
> Date: Mon, 21 Jan 2019 11:53:05 -0500
> Subject: [PATCH] gnu: mariadb: Disable sporadically failing tests.
>
> * guix/packages/databases.scm: Disable sporadically failing tests.
> ---
>  gnu/packages/databases.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 655e7c3a3..e08a179bf 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -582,6 +582,8 @@ Language.")
>                        "main.explain_non_select"
>                        "main.stat_tables_innodb"
>                        "roles.acl_statistics"
> +                      "main.mysqldump"
> +                      "innodb_fts.crash_recovery"
>
>                        ;; FIXME: This test fails on i686:
>                        ;; -myisampack: Can't create/write to file (Errcode: 17 "File exists")

Hi Carl,

Thanks for looking at this.

I'd be interested to know what the sporadic test failures look like, do
you have a error message you could share?

Currently, there is a comment that sits just above the lines you've
added which says why roles.acl_statistics and 3 other tests are
disabled, so it would be good to confirm if the reason is the same, or a
new comment is needed.

Thanks,

Chris
Ludovic Courtès Jan. 22, 2019, 9:40 p.m. UTC | #2
Hello,

Christopher Baines <mail@cbaines.net> skribis:

> I'd be interested to know what the sporadic test failures look like, do
> you have a error message you could share?

On the build farm, mariadb tests would sometimes fail in obscure ways
because they had not enough space (and they need a whole lot of disk
space!).  Could that be related?

Anyway, thanks for investigating, Carl!

Ludo’.
Eric Bavier Jan. 23, 2019, 3:47 a.m. UTC | #3
On Mon, 21 Jan 2019 16:59:44 +0000
Carl Dong <accounts@carldong.me> wrote:

> From 6963ef73ccfbbc2e22a2b90b567d65cf37a2be0a Mon Sep 17 00:00:00 2001
> From: Carl Dong <accounts@carldong.me>
> Date: Mon, 21 Jan 2019 11:53:05 -0500
> Subject: [PATCH] gnu: mariadb: Disable sporadically failing tests.
> 
> * guix/packages/databases.scm: Disable sporadically failing tests.
> ---
>  gnu/packages/databases.scm | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 655e7c3a3..e08a179bf 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -582,6 +582,8 @@ Language.")
>                        "main.explain_non_select"
>                        "main.stat_tables_innodb"
>                        "roles.acl_statistics"
> +                      "main.mysqldump"
> +                      "innodb_fts.crash_recovery"
> 
>                        ;; FIXME: This test fails on i686:
>                        ;; -myisampack: Can't create/write to file (Errcode: 17 "File exists")

Pushed to the "staging" branch, due to the 488 dependents, in commit
38f77be464b0b6ca76105d5f0a1b5e55fd694036

BTW, the "main.mysqldump" was disabled recently on the core-updates
branch in commit cbd833750a57ae0596e80d06c74b02bccddf6197.  The two can
trivially be merged later.

`~Eric

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 655e7c3a3..e08a179bf 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -582,6 +582,8 @@  Language.")
                       "main.explain_non_select"
                       "main.stat_tables_innodb"
                       "roles.acl_statistics"
+                      "main.mysqldump"
+                      "innodb_fts.crash_recovery"

                       ;; FIXME: This test fails on i686:
                       ;; -myisampack: Can't create/write to file (Errcode: 17 "File exists")