[bug#34048] gnu: z3: Update to 4.8.4.

Message ID 87o98k4mg5.fsf@aminb.org
State Accepted
Headers show
Series [bug#34048] gnu: z3: Update to 4.8.4. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Amin Bandali Jan. 13, 2019, 3:16 p.m. UTC
Hi Efraim,

[...]

> 'guix refresh -l z3' shows:
> Building the following 2 packages would ensure 3 dependent packages are rebuilt: arachne-pnr@0.0-1-52e69ed20 cubicle@1.1.2
>

TIL, thanks!

>
> so in theory it's inexpensive to test the packages. Based on
> arachne-pnr's version number, I'd check if there's a later commit that
> doesn't fail the test suite.
>

Based on your suggestion, I tried bumping arachne-pnr from its current
version in Guix from way back in 2016 to latest master from September
2018 (see the attached patch).

The build phase fails, but it seems to be for another reason than its
current failure.  However, I’ve never used arachne-pnr and don’t know
much about it.

I’ve Cc’ed Danny who originally added the package.  Danny, would you be
able to have a look and see if anything can be done to fix arachne-pnr?

The failure seems to be due to a missing txt file:

,----
| make: *** No rule to make target '/usr/local/share/icebox/chipdb-384.txt', needed by 'share/arachne-pnr/chipdb-384.bin'.  Stop.
`----

Best,
amin

Comments

Danny Milosavljevic Jan. 15, 2019, 3:48 p.m. UTC | #1
Hi,

I've updated arachne-pnr, icestorm (please make sure to also update this when
you update arachne-pnr since arachne-pnr tests require icestorm) and yosys on
guix master now.
Amin Bandali Jan. 18, 2019, 4:27 a.m. UTC | #2
Hi Danny,

On 2019-01-15  4:48 PM, Danny Milosavljevic wrote:
> Hi,
>
> I've updated arachne-pnr, icestorm (please make sure to also update this when
> you update arachne-pnr since arachne-pnr tests require icestorm) and yosys on
> guix master now.
>

Thanks; I’ll keep your advice about them in mind if I end up changing
them in the future.

With Danny’s changes the build phase for arachne-pnr passes but the
check phase fails on one of the test cases, with or without my z3 4.8.4
update patch.  I’ve attached the corresponding logs:

- gwa4kkg00rzp96jkqv52fzz4g197q4-arachne-pnr-0.0-2-840bdfdeb.drv.bz2:
  with z3 4.8.3 (without my patch)
- s1lqkz49nlp147m96bnn0d0yl21dgi-arachne-pnr-0.0-2-840bdfdeb.drv.bz2:
  with z3 4.8.4 (with my patch)

A quick glance at the ediff of the two files, I didn’t see anything
suggesting that the failure may be due to updating z3 from 4.8.3 to
4.8.4.  It might be a good idea to apply the z3 update patch and try
resolving arachne-pnr’s test suite failure in a separate issue.

Thanks,
amin
Leo Famulari Jan. 18, 2019, 4:14 p.m. UTC | #3
On Thu, Jan 17, 2019 at 11:27:40PM -0500, Amin Bandali wrote:
> With Danny’s changes the build phase for arachne-pnr passes but the
> check phase fails on one of the test cases, with or without my z3 4.8.4
> update patch.  I’ve attached the corresponding logs:
> 
> - gwa4kkg00rzp96jkqv52fzz4g197q4-arachne-pnr-0.0-2-840bdfdeb.drv.bz2:
>   with z3 4.8.3 (without my patch)
> - s1lqkz49nlp147m96bnn0d0yl21dgi-arachne-pnr-0.0-2-840bdfdeb.drv.bz2:
>   with z3 4.8.4 (with my patch)
> 
> A quick glance at the ediff of the two files, I didn’t see anything
> suggesting that the failure may be due to updating z3 from 4.8.3 to
> 4.8.4.  It might be a good idea to apply the z3 update patch and try
> resolving arachne-pnr’s test suite failure in a separate issue.

Thanks for investigating. I've pushed the z3 update as
6654f8c1447d80c4899c4234306801407315b31f

Patch

From b2ad4c311a19d96110790b4e0537cfbcd1999a1a Mon Sep 17 00:00:00 2001
From: Amin Bandali <bandali@gnu.org>
Date: Sun, 13 Jan 2019 10:07:11 -0500
Subject: [PATCH] gnu: arachne-pnr: Update to 840bdfdeb.

* gnu/packages/fpga.scm (arachne-pnr): Update to 840bdfdeb.
---
 gnu/packages/fpga.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 9ab2e3525..79966e266 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -256,7 +257,7 @@  Includes the actual FTDI connector.")
     (license license:isc))))
 
 (define-public arachne-pnr
-  (let ((commit "52e69ed207342710080d85c7c639480e74a021d7")
+  (let ((commit "840bdfdeb38809f9f6af4d89dd7b22959b176fdd")
         (revision "1"))
    (package
     (name "arachne-pnr")
@@ -264,12 +265,12 @@  Includes the actual FTDI connector.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/cseed/arachne-pnr.git")
+                     (url "https://github.com/YosysHQ/arachne-pnr.git")
                      (commit commit)))
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                 (base32
-                   "15bdw5yxj76lxrwksp6liwmr6l1x77isf4bs50ys9rsnmiwh8c3w"))))
+                   "1dqvjvgvsridybishv4pnigw9gypxh7r7nrqp9z9qq92v7c5rxzl"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -294,7 +295,7 @@  Includes the actual FTDI connector.")
        ("yosys" ,yosys) ; for tests
        ("perl" ,perl) ; for shasum
        ("python-2" ,python-2))) ; for tests
-    (home-page "https://github.com/cseed/arachne-pnr")
+    (home-page "https://github.com/YosysHQ/arachne-pnr")
     (synopsis "Place-and-Route tool for FPGAs")
     (description "Arachne-PNR is a Place-and-Route Tool For FPGAs.")
     (license license:gpl2))))
-- 
2.20.1