[bug#33956] gnu: Add emacs-tldr.

Message ID 87ftuaix63.fsf@gmail.com
State Accepted
Headers show
Series [bug#33956] gnu: Add emacs-tldr. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Jan. 2, 2019, 4:03 p.m. UTC
* gnu/packages/emacs.scm (emacs-tldr): New variable.
---
 gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ludovic Courtès Jan. 13, 2019, 10:24 p.m. UTC | #1
Gabriel Hondet <gabrielhondet@gmail.com> skribis:

> * gnu/packages/emacs.scm (emacs-tldr): New variable.

Applied, thanks!

Ludo'.

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ffb5a1518..58c6e718c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12961,3 +12961,25 @@  other frame parameters.")
       (description "Emacs major mode for editing Arduino sketches.")
       (home-page "https://github.com/bookest/arduino-mode")
       (license license:gpl3+))))
+
+(define-public emacs-tldr
+  (let ((commit "398b197c8d2238628b07e1b32d0f373876279f4c"))
+    (package
+      (name "emacs-tldr")
+      (version (git-version "0" "0" commit))
+      (home-page "https://github.com/kuanyui/tldr.el")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url (string-append home-page ".git"))
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "0iq7qlis6c6r2qkdpncrhh5vsihkhvy5x4y1y8cjb7zxkh62w33f"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (synopsis "Simplified and community-driven man pages for emacs")
+      (description "@code{emacs-tldr} allows the user to access tldr pages
+from within emacs.  The @code{tldr} pages are a community effort to simplify
+the man pages with practical examples.")
+      (license license:wtfpl2))))