[bug#34021,1/1] gnu: kinit: Use KDEINIT5_LIBRARY_PATH to search for dynlibs.

Message ID 20190109160246.23799-1-h.goebel@crazy-compilers.com
State Accepted
Commit 46b082f97f73cd79b40bde15cfe3e4ddb28ba209
Headers show
Series [bug#34021,1/1] gnu: kinit: Use KDEINIT5_LIBRARY_PATH to search for dynlibs. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Hartmut Goebel Jan. 9, 2019, 4:02 p.m. UTC
Using LIBRARY_PATH was introduced in
16b8aff85bcdb9799496c4a27257210cd45158e5, but is wrong since
this variable is used by the compiler (gcc) at link time.

* gnu/packages/patches/kinit-kdeinit-libpath.patch: Change
  LIBRARY_PATH to KDEINIT5_LIBRARY_PATH.
* gnu/packages/kde-frameworks.scm (kinit)[native-search-paths]:
  New field.
---
 gnu/packages/kde-frameworks.scm                  | 4 ++++
 gnu/packages/patches/kinit-kdeinit-libpath.patch | 2 +-
 2 files changed, 5 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Jan. 11, 2019, 10:26 a.m. UTC | #1
Hello Hartmut,

Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

> Using LIBRARY_PATH was introduced in
> 16b8aff85bcdb9799496c4a27257210cd45158e5, but is wrong since
> this variable is used by the compiler (gcc) at link time.
>
> * gnu/packages/patches/kinit-kdeinit-libpath.patch: Change
>   LIBRARY_PATH to KDEINIT5_LIBRARY_PATH.
> * gnu/packages/kde-frameworks.scm (kinit)[native-search-paths]:
>   New field.

LGTM, thanks!

Ludo’.
Hartmut Goebel Jan. 11, 2019, 3:39 p.m. UTC | #2
Commited as 46b082f97f73cd79b40bde15cfe3e4ddb28ba209

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 62cd2dd2d..72152fd78 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2556,6 +2556,10 @@  in applications using the KDE Frameworks.")
                (("GUIX_PKGS_KF5_PARTS") (assoc-ref inputs "kparts"))
                (("GUIX_PKGS_KF5_PLASMA") (assoc-ref inputs "plasma-framework")))
              #t)))))
+    (native-search-paths
+     (list (search-path-specification
+            (variable "KDEINIT5_LIBRARY_PATH")
+            (files '("lib/")))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/kinit-kdeinit-libpath.patch b/gnu/packages/patches/kinit-kdeinit-libpath.patch
index 89cf1a941..6382e8804 100644
--- a/gnu/packages/patches/kinit-kdeinit-libpath.patch
+++ b/gnu/packages/patches/kinit-kdeinit-libpath.patch
@@ -23,7 +23,7 @@  pkgs/development/libraries/kde-frameworks/kinit/kinit-libpath.patch
 -                    l.load();
 -                }
 +                // Try to load the library relative to the active profiles.
-+                QByteArrayList profiles = qgetenv("LIBRARY_PATH").split(':');
++                QByteArrayList profiles = qgetenv("KDEINIT5_LIBRARY_PATH").split(':');
 +                for (const QByteArray &profile: profiles) {
 +                    if (!profile.isEmpty()) {
 +                        l.setFileName(QFile::decodeName(profile) + QStringLiteral("/") + libpath);