[bug#34025] Update meson to 0.49.0

Message ID CAOm0rWCaBWaKTr7cgJEsfcMnRJrh6KogFmj=Y+i5wKz4opSu-w@mail.gmail.com
State Accepted
Headers show
Series [bug#34025] Update meson to 0.49.0 | expand

Checks

Context Check Description
cbaines/package builds pending In Cuirass
cbaines/applying patch fail Apply failed

Commit Message

sdilts Jan. 9, 2019, 10:50 p.m. UTC
* gnu/packages/build-tools.scm: update the version and sha256 hash
---
 gnu/packages/build-tools.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

               (uri (string-append "https://github.com/mesonbuild/meson/"
@@ -166,7 +166,7 @@ files and generates build instructions for the Ninja
build system.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1swmycf6p9p0ag6yiywyyri42ffkxxj38r2ic7in24km47cszn4j"))))
+                "0l8m1v7cl5ybm7psfqmmdqbvmnsbb1qhb8ni3hwap3i0mk29a0zv"))))
     (build-system python-build-system)
     (arguments
      `(;; FIXME: Tests require many additional inputs, a fix for the
RUNPATH

Comments

Leo Famulari Jan. 10, 2019, 1:02 a.m. UTC | #1
On Wed, Jan 09, 2019 at 03:50:58PM -0700, Stuart Dilts wrote:
> * gnu/packages/build-tools.scm: update the version and sha256 hash

Thank you for sending this patch!

We actually already have this change on the 'staging' branch [0], in commit
f06fdbae8d6318fdabf9c1eb686e2bfa2b9ff18a.

Updating meson will trigger a rebuild of all the packages that use the
meson-build-system.

I'm not sure how to find out exactly how many packages directly and
indirectly depend on the meson-build-system, but since the change was
pushed to the staging branch, it's probably more than 300, which is the
limit for changes on the master branch.

The manual section Submitting Patches describes the guidelines for how
many rebuilds are acceptable on the master, staging, and core-updates
branches:

https://www.gnu.org/software/guix/manual/en/html_node/Submitting-Patches.html

[0] https://git.savannah.gnu.org/cgit/guix.git/log/?h=staging
Efraim Flashner Jan. 10, 2019, 7:24 a.m. UTC | #2
On Wed, Jan 09, 2019 at 08:02:47PM -0500, Leo Famulari wrote:
> On Wed, Jan 09, 2019 at 03:50:58PM -0700, Stuart Dilts wrote:
> > * gnu/packages/build-tools.scm: update the version and sha256 hash
> 
> Thank you for sending this patch!
> 
> We actually already have this change on the 'staging' branch [0], in commit
> f06fdbae8d6318fdabf9c1eb686e2bfa2b9ff18a.
> 
> Updating meson will trigger a rebuild of all the packages that use the
> meson-build-system.
> 
> I'm not sure how to find out exactly how many packages directly and
> indirectly depend on the meson-build-system, but since the change was
> pushed to the staging branch, it's probably more than 300, which is the
> limit for changes on the master branch.
> 

guix refresh -l -e '(@@ (gnu packages build-tools) meson-for-build)'

another one that I've triggered accidentally is libva
Leo Famulari Jan. 10, 2019, 8:22 p.m. UTC | #3
On Thu, Jan 10, 2019 at 09:24:27AM +0200, Efraim Flashner wrote:
> On Wed, Jan 09, 2019 at 08:02:47PM -0500, Leo Famulari wrote:
> > On Wed, Jan 09, 2019 at 03:50:58PM -0700, Stuart Dilts wrote:
> > > * gnu/packages/build-tools.scm: update the version and sha256 hash
> > 
> > Thank you for sending this patch!
> > 
> > We actually already have this change on the 'staging' branch [0], in commit
> > f06fdbae8d6318fdabf9c1eb686e2bfa2b9ff18a.
> > 
> > Updating meson will trigger a rebuild of all the packages that use the
> > meson-build-system.
> > 
> > I'm not sure how to find out exactly how many packages directly and
> > indirectly depend on the meson-build-system, but since the change was
> > pushed to the staging branch, it's probably more than 300, which is the
> > limit for changes on the master branch.
> > 
> 
> guix refresh -l -e '(@@ (gnu packages build-tools) meson-for-build)'
> 
> another one that I've triggered accidentally is libva

Oh... I missed this package :)

So, Stuart, can you send a revised patch that updates the 'meson'
package while keeping 'meson-for-build' at 0.47.2?

The trick is to make the new meson available without having to rebuild
the Guix packages that use meson-for-build.

Concretely, you'd need to add a 'version' field to meson-for-build to
keep it at 0.47.2, and to add 'uri', and 'sha256' fields so that it
uses the correct source code.

You can check that meson-for-build is unchanged by comparing the
derivations before and after your modifications:

$ ./pre-inst-env guix build -d -e '(@@ (gnu packages build-tools) meson-for-build)'
/gnu/store/l5vlmc040fz2zmnb45vhbqhs6pi7iw6v-meson-for-build-0.47.2.drv

Because meson-for-build is a hidden package, you need to specify it with
that Scheme expression.

Patch

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index a34e7eb..628b36f 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -158,7 +158,7 @@  files and generates build instructions for the Ninja
build system.")
 (define-public meson
   (package
     (name "meson")
-    (version "0.47.2")
+    (version "0.49.0")
     (source (origin
               (method url-fetch)