From 939547e6e2c0f5a83eb1290ff1c9ee39415ce3d5 Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Fri, 4 Jan 2019 22:34:56 +0100
Subject: [PATCH 2/2] gnu: Use package-elisp-from-package for clangs emacs lisp
files
Use package-elisp-from-package for emacs-clang-format and emacs-clang-rename.
Also remove package-from-clang-elisp-file as it is not needed anymore.
* gnu/packages/llvm.scm (emacs-clang-format): Use package-elisp-from-package
* gnu/packages/llvm.scm (emacs-clang-rename): Use package-elisp-from-package
* gnu/packages/llvm.scm (package-from-clang-elisp-file): Remove function
---
gnu/packages/llvm.scm | 63 +++++++++++++++++++++----------------------
1 file changed, 31 insertions(+), 32 deletions(-)
@@ -39,6 +39,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages bootstrap) ;glibc-dynamic-linker
#:use-module (gnu packages compression)
+ #:use-module (gnu packages emacs)
#:use-module (gnu packages libffi)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -540,22 +541,21 @@ the files SOURCE-FILES from the source in its root directory."
(define-public emacs-clang-format
(package
- (inherit clang)
- (name "emacs-clang-format")
- (build-system emacs-build-system)
- (inputs
- `(("clang" ,clang)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((clang (assoc-ref inputs "clang")))
- (copy-file "tools/clang-format/clang-format.el" "clang-format.el")
- (emacs-substitute-variables "clang-format.el"
- ("clang-format-executable"
- (string-append clang "/bin/clang-format"))))
- #t)))))
+ (inherit (package-elisp-from-package
+ clang
+ "emacs-clang-format"
+ '("tools/clang-format/clang-format.el")))
+ (inputs `(("clang" ,clang)))
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (chmod "clang-format.el" #o644)
+ (emacs-substitute-variables "clang-format.el"
+ ("clang-format-executable"
+ (string-append (assoc-ref inputs "clang")
+ "/bin/clang-format")))
+ #t)))))
(synopsis "Format code using clang-format")
(description "This package allows to filter code through @code{clang-format}
to fix its formatting. @code{clang-format} is a tool that formats
@@ -564,22 +564,21 @@ C/C++/Obj-C code according to a set of style options, see
(define-public emacs-clang-rename
(package
- (inherit clang)
- (name "emacs-clang-rename")
- (build-system emacs-build-system)
- (inputs
- `(("clang" ,clang)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((clang (assoc-ref inputs "clang")))
- (copy-file "tools/clang-rename/clang-rename.el" "clang-rename.el")
- (emacs-substitute-variables "clang-rename.el"
- ("clang-rename-binary"
- (string-append clang "/bin/clang-rename"))))
- #t)))))
+ (inherit (package-elisp-from-package
+ clang
+ "emacs-clang-rename"
+ '("tools/clang-rename/clang-rename.el")))
+ (inputs `(("clang" ,clang)))
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (chmod "clang-rename.el" #o644)
+ (emacs-substitute-variables "clang-rename.el"
+ ("clang-rename-binary"
+ (string-append (assoc-ref inputs "clang")
+ "/bin/clang-rename")))
+ #t)))))
(synopsis "Rename every occurrence of a symbol using clang-rename")
(description "This package renames every occurrence of a symbol at point
using @code{clang-rename}.")))
--
2.20.1