[bug#33909,3/7] gnu: Add emacs-treepy.

Message ID 20181229150301.30567-4-jlicht@fsfe.org
State Accepted
Commit abb8dff054a9e27fcb2b1f4d2d08c2fb66917f84
Headers show
Series Prepare for release of emacs-forge | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Jelle Licht Dec. 29, 2018, 3:02 p.m. UTC
* gnu/packages/emacs.scm (emacs-treepy): New variable.
---
 gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Ludovic Courtès Jan. 9, 2019, 3:43 p.m. UTC | #1
Jelle Licht <jlicht@fsfe.org> skribis:

> * gnu/packages/emacs.scm (emacs-treepy): New variable.

LGTM!

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 0e1a525ab..2e441d41a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -627,6 +627,28 @@  these arguments.  The prototypical use is for the command to call an external
 process, passing on the arguments as command line arguments.")
     (license license:gpl3+)))
 
+(define-public emacs-treepy
+  (package
+    (name "emacs-treepy")
+    (version "0.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/volrath/treepy.el.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "04zwm6gx9pxfvgfkizx6pvb1ql8pqxjyzqp8flz0432x0gq5nlxk"))))
+    (build-system emacs-build-system)
+    (home-page
+     "https://github.com/volrath/treepy.el")
+    (synopsis "Tree traversal tools")
+    (description
+     "Generic tools for recursive and iterative tree traversal based on
+clojure.walk and clojure.zip respectively.")
+    (license license:gpl3+)))
+
 (define-public emacs-ghub
   (package
     (name "emacs-ghub")