[bug#33908,2/7] gnu: emacs-emacsql: Update to 3.0.0.

Message ID 20181229150301.30567-3-jlicht@fsfe.org
State Accepted
Commit 56c50c71b57b03251474f9ece4d1f2a6359d33f4
Headers show
Series Prepare for release of emacs-forge | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Jelle Licht Dec. 29, 2018, 3:02 p.m. UTC
* gnu/packages/emacs.scm (emacs-emacsql): Update to 3.0.0.
[source]: Use 'git-fetch'.
[arguments]: Remove unnecessary fix.
---
 gnu/packages/emacs.scm | 22 ++++++++++------------
 1 file changed, 10 insertions(+), 12 deletions(-)

Comments

Ludovic Courtès Jan. 9, 2019, 3:43 p.m. UTC | #1
Jelle Licht <jlicht@fsfe.org> skribis:

> * gnu/packages/emacs.scm (emacs-emacsql): Update to 3.0.0.
> [source]: Use 'git-fetch'.
> [arguments]: Remove unnecessary fix.

LGTM!

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c0d6635de..0e1a525ab 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -8825,16 +8825,16 @@  object has been freed.")
 (define-public emacs-emacsql
   (package
     (name "emacs-emacsql")
-    (version "2.0.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/skeeto/emacsql/archive/"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "04hfjdgl1zc7jysgjc7d7d3xqpr7q1q9gsmzffjd91ii3hpqjgx6"))))
+    (version "3.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/skeeto/emacsql.git")
+                    (commit (string-append version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c84gxr1majqj4b59wgdy3lzm3ap66w9qsrnkx8hdbk9895ak81g"))))
     (build-system emacs-build-system)
     (arguments
      `(#:modules ((guix build emacs-build-system)
@@ -8869,8 +8869,6 @@  object has been freed.")
              (let ((file "emacsql-sqlite.el"))
                (chmod file #o644)
                (emacs-substitute-sexps file
-                 ;; Avoid interactive prompts.
-                 ("(defvar emacsql-sqlite-user-prompted" 't)
                  ;; Make sure Emacs looks for ‘GCC’ binary in the right place.
                  ("(executable-find" (which "gcc"))
                  ;; Make sure Emacs looks for ‘emacsql-sqlite’ binary